Skip to content

← Actionable
Medium, CVSS 6.5amended

Froxlor has CSRF Vulnerability in AJAX Endpoint — Missing Cross-Site Request Forgery Protection

CVE-2026-55593GHSA-xpr4-8vp6-c87j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (froxlor/froxlor 2.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-55593: 0.26% estimated exploitation activity in the next 30 days; percentile 17.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Froxlor AJAX endpoint (lib/ajax.php) is missing Cross-Site Request Forgery (CSRF) protection. While the main application (lib/init.php) enforces CSRF token validation on all state-changing HTTP requests (POST/PUT/PATCH/DELETE), the standalone lib/ajax.php endpoint bypasses this mechanism entirely, validating only the user's session. An attacker can craft a malicious webpage that, when visited by an authenticated Froxlor administrator, silently modifies API key properties (e.g., adding the attacker's IP to the allowedfrom whitelist or extending the validuntil expiration). --- Affected Component - File: lib/ajax.php — the AJAX endpoint entry point (bypasses lib/init.php) - File: lib/Froxlor/Ajax/Ajax.php:66-92 — Ajax::handle() (no CSRF check before routing) - File: lib/Froxlor/Ajax/Ajax.php:257-315 — Ajax::editApiKey() (writes to database without CSRF check) - Version: Froxlor 2.3.7 (likely all prior 2.x versions) --- Complete Call Chain: Entry Point → Vulnerable Code Step…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xpr4-8vp6-c87j

  2. Revision 1 · created ·

    Published from osv record GHSA-xpr4-8vp6-c87j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55593

Advisory: Froxlor has CSRF Vulnerability in AJAX Endpoint — Missing Cross-Site Request Forgery Protection
IDs: CVE-2026-55593, GHSA-xpr4-8vp6-c87j
Record: https://patchnext.com/advisories/cve-2026-55593 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: froxlor/froxlor 2.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist froxlor/froxlor: affected <= 2.3.7; fixed in 2.3.8

## Suggested inspection (read-only)
- Packagist froxlor/froxlor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on froxlor/froxlor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xpr4-8vp6-c87j (OSV record GHSA-xpr4-8vp6-c87j lists affected ranges: Packagist froxlor/froxlor >=0 <2.3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-xpr4-8vp6-c87j (GitHub-reviewed advisory GHSA-xpr4-8vp6-c87j lists affected ranges: Packagist froxlor/froxlor >=0 <=2.3.7)

Commands are suggestions: review each one before running it.

Loading voting…