Signal K Server: Server-Side Request Forgery via Remote Connection Endpoints
CVE-2026-55591GHSA-q59x-jc9f-gfqf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (signalk-server 2.28.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm signalk-server
- Affected
- <= 2.27.0
- Fixed in
- 2.28.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q59x-jc9f-gfqf lists affected ranges: npm signalk-server >=0 <2.28.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q59x-jc9f-gfqf lists affected ranges: npm signalk-server >=0 <=2.27.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2026-55591: 0.30% estimated exploitation activity in the next 30 days; percentile 22.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary signalk-server versions up to and including 2.27.0 contain a Server-Side Request Forgery (SSRF) vulnerability in three administrative endpoints used for remote Signal K server connection management. The makeRemoteRequest() function accepts attacker-controlled host, port, useTLS, and selfsignedcert parameters without any validation, allowing an attacker to force the server to make arbitrary HTTP/HTTPS requests to internal network resources, cloud metadata services, and other unintended destinations. When security is not configured (the default state), these endpoints require no authentication. Details Vulnerable Function The core vulnerability is in makeRemoteRequest() at src/serverroutes.ts:2483-2524: Missing Validation The function performs zero validation on the destination host. The following address ranges are all reachable: - Loopback: 127.0.0.1, ::1, localhost - RFC 1918 private ranges: 10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16 - Link-local / Cloud metadata:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q59x-jc9f-gfqf
- Revision 1 · created ·
Published from osv record GHSA-q59x-jc9f-gfqf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55591 Advisory: Signal K Server: Server-Side Request Forgery via Remote Connection Endpoints IDs: CVE-2026-55591, GHSA-q59x-jc9f-gfqf Record: https://patchnext.com/advisories/cve-2026-55591 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: signalk-server 2.28.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm signalk-server: affected <= 2.27.0; fixed in 2.28.0 ## Suggested inspection (read-only) - `npm ls signalk-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on signalk-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q59x-jc9f-gfqf (OSV record GHSA-q59x-jc9f-gfqf lists affected ranges: npm signalk-server >=0 <2.28.0 (fixed)) - Verified: https://github.com/advisories/GHSA-q59x-jc9f-gfqf (GitHub-reviewed advisory GHSA-q59x-jc9f-gfqf lists affected ranges: npm signalk-server >=0 <=2.27.0) Commands are suggestions: review each one before running it.
Loading voting…