Skip to content

← Actionable
Medium, CVSS 5.1

CakePHP Authentication: Open redirect weakness via backslash bypass

CVE-2026-55590GHSA-hhpq-7wg4-36jm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/authentication 4.1.1, 3.3.6, 2.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist cakephp/authentication

    Affected
    >= 4.0.0, < 4.1.1>= 3.0.0, < 3.3.6< 2.11.1
    Fixed in
    3.3.6, 2.11.1, 4.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-55590: 0.49% estimated exploitation activity in the next 30 days; percentile 42.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The getLoginRedirect() method contains a weakness to backslash bypasses allowing redirect targets with attacker controlled hostnames. Patches 2.11.1, 3.3.6 and 4.1.1 contain a fix for this issue. Workarounds If you are unable to upgrade, you should consider adding application validation to the redirect query string parameter to mitigate this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hhpq-7wg4-36jm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55590

Advisory: CakePHP Authentication: Open redirect weakness via backslash bypass
IDs: CVE-2026-55590, GHSA-hhpq-7wg4-36jm
Record: https://patchnext.com/advisories/cve-2026-55590 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cakephp/authentication 4.1.1, 3.3.6, 2.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cakephp/authentication: affected >= 4.0.0, < 4.1.1; >= 3.0.0, < 3.3.6; < 2.11.1; fixed in 3.3.6, 2.11.1, 4.1.1

## Suggested inspection (read-only)
- Packagist cakephp/authentication: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cakephp/authentication.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hhpq-7wg4-36jm (GitHub-reviewed advisory GHSA-hhpq-7wg4-36jm lists affected ranges: Packagist cakephp/authentication >=4.0.0 =3.0.0 =0 <2.11.1)

Commands are suggestions: review each one before running it.

Loading voting…