phpSysInfo has an IP allowlist (PSI_ALLOWED) bypass via spoofed X-Forwarded-For / Client-IP headers
CVE-2026-55584GHSA-786w-p5pm-cvgh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpsysinfo/phpsysinfo 3.4.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpsysinfo/phpsysinfo
- Affected
- <= 3.4.5
- Fixed in
- 3.4.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-786w-p5pm-cvgh lists affected ranges: Packagist phpsysinfo/phpsysinfo >=0 <3.4.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-786w-p5pm-cvgh lists affected ranges: Packagist phpsysinfo/phpsysinfo >=0 <=3.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-55584: 1.91% estimated exploitation activity in the next 30 days; percentile 79.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary phpSysInfo's PSIALLOWED IP allowlist can be trivially bypassed by any unauthenticated remote attacker. The access-control check in readconfig.php derives the client IP from the attacker-controlled X-Forwarded-For and Client-IP HTTP headers before falling back to REMOTEADDR. An attacker can send X-Forwarded-For: <an allowed IP to impersonate a trusted address and gain full access to all exposed system information, defeating the only IP-based access restriction the application provides. Affected component - File: readconfig.php - Versions: all versions up to and including 3.4.x (current main) Description When PSIALLOWED is configured, readconfig.php enforces an IP allowlist. The client IP is resolved as follows: Both HTTPXFORWARDEDFOR and HTTPCLIENTIP are fully attacker-controlled request headers. They are trusted unconditionally and take priority over REMOTEADDR. There is no concept of a configured/trusted reverse proxy, so even when phpSysInfo is exposed directly (no proxy in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-786w-p5pm-cvgh
- Revision 1 · created ·
Published from osv record GHSA-786w-p5pm-cvgh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55584 Advisory: phpSysInfo has an IP allowlist (PSI_ALLOWED) bypass via spoofed X-Forwarded-For / Client-IP headers IDs: CVE-2026-55584, GHSA-786w-p5pm-cvgh Record: https://patchnext.com/advisories/cve-2026-55584 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpsysinfo/phpsysinfo 3.4.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpsysinfo/phpsysinfo: affected <= 3.4.5; fixed in 3.4.6 ## Suggested inspection (read-only) - Packagist phpsysinfo/phpsysinfo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpsysinfo/phpsysinfo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-786w-p5pm-cvgh (OSV record GHSA-786w-p5pm-cvgh lists affected ranges: Packagist phpsysinfo/phpsysinfo >=0 <3.4.6 (fixed)) - Verified: https://github.com/advisories/GHSA-786w-p5pm-cvgh (GitHub-reviewed advisory GHSA-786w-p5pm-cvgh lists affected ranges: Packagist phpsysinfo/phpsysinfo >=0 <=3.4.5) Commands are suggestions: review each one before running it.
Loading voting…