Skip to content

← Actionable
High, CVSS 8.4amended

mcp-shell has a Secure Mode Allowlist Bypass via Default /bin/bash Executable

CVE-2026-55581GHSA-3x77-wg38-92r3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/sonirico/mcp-shell 0.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-55581: 0.45% estimated exploitation activity in the next 30 days; percentile 39.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary mcp-shell ships a default Docker configuration (security.yaml) that includes /bin/bash in the allowedexecutables allowlist. The command validator (security.go) only checks whether the first token of the supplied command matches an allowed executable; it does not inspect or reject shell command-mode flags such as -c. As a result, any MCP tool caller can send command=/bin/bash -c <arbitrary-command to the shellexec tool and execute commands that are not in the allowlist — including id, env, curl, wget, and any other binary present in the container. The bypass works with the default Docker image, requires no authentication, and requires no modifications to server configuration. Successful exploitation gives the attacker arbitrary OS command execution inside the container as mcpuser. Details mcp-shell implements a secure mode in which command execution is restricted to an explicit allowlist of executables defined in security.yaml. The Docker image ships this file with the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3x77-wg38-92r3

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6290

  3. Revision 1 · created ·

    Published from osv record GHSA-3x77-wg38-92r3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55581

Advisory: mcp-shell has a Secure Mode Allowlist Bypass via Default `/bin/bash` Executable
IDs: CVE-2026-55581, GHSA-3x77-wg38-92r3
Record: https://patchnext.com/advisories/cve-2026-55581 (revision 3, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/sonirico/mcp-shell 0.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/sonirico/mcp-shell: affected < 0.6.0; fixed in 0.6.0

## Suggested inspection (read-only)
- Go github.com/sonirico/mcp-shell: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/sonirico/mcp-shell.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3x77-wg38-92r3 (OSV record GHSA-3x77-wg38-92r3 lists affected ranges: Go github.com/sonirico/mcp-shell >=0 <0.6.0 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6290 (OSV record GO-2026-6290 lists affected ranges: Go github.com/sonirico/mcp-shell >=0 <0.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3x77-wg38-92r3 (GitHub-reviewed advisory GHSA-3x77-wg38-92r3 lists affected ranges: Go github.com/sonirico/mcp-shell >=0 <0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…