Yamcs has DOM XSS in Extension Routing
CVE-2026-55566GHSA-9272-wg2r-7xmx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.yamcs:yamcs-core 5.13.2, 5.12.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.yamcs:yamcs-core
- Affected
- >= 5.13.0, <= 5.13.1<= 5.12.7
- Fixed in
- 5.12.8, 5.13.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9272-wg2r-7xmx lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <5.12.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9272-wg2r-7xmx lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <=5.12.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-55566: 0.38% estimated exploitation activity in the next 30 days; percentile 32.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Attack type: Unauthenticated remote Impact: Execution of arbitrary JavaScript in a user’s browser. Affected components: extension.matcher.ts:12, extension.component.ts:40, app.component.ts:134. Yamcs is vulnerable to cross-site scripting in the /ext URL endpoint. By inputting specially crafted code into the URL, an attacker can execute arbitrary JavaScript code in a user’s browser. This URL may be sent to a user via a phishing email. <img width="940" height="294" alt="image" src="https://github.com/user-attachments/assets/d886d65c-9bb5-4599-ac11-55db83aafc0e" / Steps to Reproduce: 1. Start a Yamcs instance. 2. Insert the following URL into the browser and press enter (change ‘myproject’ to the name of your instance): 3. You will receive an alert with the number ‘1’ in it. Recommendations: 1. Use document.createElement instead of innerHTML in extension.component.ts. 2. Validate the extension against registered plugin IDs. 3. Enforce a strict custom-element-name regex before mounting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9272-wg2r-7xmx
- Revision 1 · created ·
Published from osv record GHSA-9272-wg2r-7xmx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55566 Advisory: Yamcs has DOM XSS in Extension Routing IDs: CVE-2026-55566, GHSA-9272-wg2r-7xmx Record: https://patchnext.com/advisories/cve-2026-55566 (revision 2, source checked 26 Oct 2026, 16:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.yamcs:yamcs-core 5.13.2, 5.12.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.yamcs:yamcs-core: affected >= 5.13.0, <= 5.13.1; <= 5.12.7; fixed in 5.12.8, 5.13.2 ## Suggested inspection (read-only) - Maven org.yamcs:yamcs-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.yamcs:yamcs-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9272-wg2r-7xmx (OSV record GHSA-9272-wg2r-7xmx lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <5.12.8 (fixed)) - Verified: https://github.com/advisories/GHSA-9272-wg2r-7xmx (GitHub-reviewed advisory GHSA-9272-wg2r-7xmx lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <=5.12.7) Commands are suggestions: review each one before running it.
Loading voting…