Skip to content

← Actionable
Critical, CVSS 9.9amended

Yamcs vulnerable to authenticated remote code execution via unescaped StreamSQL LIKE pattern compiled by Janino (LikeExpression)

CVE-2026-55565GHSA-c64q-hj4j-375f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.yamcs:yamcs-core 5.13.2, 5.12.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-55565: 0.65% estimated exploitation activity in the next 30 days; percentile 51.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Yamcs compiles StreamSQL query expressions to Java at runtime with Janino. The LIKE operator inserts the user-supplied pattern into the generated Java unescaped, inside a "..." literal, so a pattern containing " breaks out and injects arbitrary Java (e.g. a static{} block that runs an OS command when the compiled filter class loads). Result: RCE as the OS user running Yamcs. The pattern is embedded raw whether it comes from a SQL string literal or a bound ? argument, so the sink is reachable from any endpoint that builds a LIKE from user input, at routine read-only privileges, not just executeSql: - POST /api/archive/{instance}:executeSql and :streamSql (privilege ControlArchiving) - POST /api/archive/{instance}/tables/{table}:readRows via the query field (privilege ReadTables) - GET /api/archive/{instance}/events?q= and the event export/stream variants (privilege ReadEvents) - listActivities q (privilege ReadActivities) The Events page search box feeds q directly.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c64q-hj4j-375f

  2. Revision 1 · created ·

    Published from osv record GHSA-c64q-hj4j-375f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55565

Advisory: Yamcs vulnerable to authenticated remote code execution via unescaped StreamSQL `LIKE` pattern compiled by Janino (`LikeExpression`)
IDs: CVE-2026-55565, GHSA-c64q-hj4j-375f
Record: https://patchnext.com/advisories/cve-2026-55565 (revision 2, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.yamcs:yamcs-core 5.13.2, 5.12.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.yamcs:yamcs-core: affected >= 5.13.0, <= 5.13.1; <= 5.12.7; fixed in 5.12.8, 5.13.2

## Suggested inspection (read-only)
- Maven org.yamcs:yamcs-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.yamcs:yamcs-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c64q-hj4j-375f (OSV record GHSA-c64q-hj4j-375f lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <5.12.8 (fixed))
- Verified: https://github.com/advisories/GHSA-c64q-hj4j-375f (GitHub-reviewed advisory GHSA-c64q-hj4j-375f lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <=5.12.7)

Commands are suggestions: review each one before running it.

Loading voting…