Yamcs: Insecure Direct Object Reference (IDOR) in PacketsApi allows unprivileged users to dump all telemetry packets
CVE-2026-55548GHSA-8xjq-pr36-ccgf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.yamcs:yamcs-core 5.13.2, 5.12.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.yamcs:yamcs-core
- Affected
- >= 5.13.0, <= 5.13.1<= 5.12.7
- Fixed in
- 5.12.8, 5.13.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8xjq-pr36-ccgf lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <5.12.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8xjq-pr36-ccgf lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <=5.12.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-55548: 0.36% estimated exploitation activity in the next 30 days; percentile 29.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The PacketsApi.exportPackets endpoint in Yamcs fails to properly enforce object-level privileges (ReadPacket) when an API request omits specific packet names. As a result, an attacker with a low-privileged account (or any authenticated user with zero privileges) can dump the entire archive of raw telemetry packets for a Yamcs instance. This leads to a massive Information Disclosure of sensitive mission telemetry, completely bypassing the intended Role-Based Access Control (RBAC) model. Vulnerability Details In yamcs-core/src/main/java/org/yamcs/http/api/PacketsApi.java, the exportPackets method processes requests to export raw packets from the tm (telemetry archive) table. The method attempts to verify privileges using ctx.checkObjectPrivileges(ObjectPrivilegeType.ReadPacket, nameSet). However, if the request.getNameList() is empty (i.e., the attacker does not specify any packet names to filter by), nameSet is empty. The checkObjectPrivileges method loops over this empty set…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8xjq-pr36-ccgf
- Revision 1 · created ·
Published from osv record GHSA-8xjq-pr36-ccgf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55548 Advisory: Yamcs: Insecure Direct Object Reference (IDOR) in PacketsApi allows unprivileged users to dump all telemetry packets IDs: CVE-2026-55548, GHSA-8xjq-pr36-ccgf Record: https://patchnext.com/advisories/cve-2026-55548 (revision 2, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.yamcs:yamcs-core 5.13.2, 5.12.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.yamcs:yamcs-core: affected >= 5.13.0, <= 5.13.1; <= 5.12.7; fixed in 5.12.8, 5.13.2 ## Suggested inspection (read-only) - Maven org.yamcs:yamcs-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.yamcs:yamcs-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8xjq-pr36-ccgf (OSV record GHSA-8xjq-pr36-ccgf lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <5.12.8 (fixed)) - Verified: https://github.com/advisories/GHSA-8xjq-pr36-ccgf (GitHub-reviewed advisory GHSA-8xjq-pr36-ccgf lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <=5.12.7) Commands are suggestions: review each one before running it.
Loading voting…