Skip to content

← Actionable
Medium, CVSS 4.3amended

Yamcs's Missing Authorization on Role and Privilege Enumeration Endpoints Allows Any Authenticated User to Disclose Full Security Configuration

CVE-2026-55547GHSA-cvw4-55pp-3hfq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.yamcs:yamcs-core 5.13.2, 5.12.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-55547: 0.34% estimated exploitation activity in the next 30 days; percentile 27.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Missing authorization checks on three IAM API endpoints (GET /api/roles, GET /api/roles/{name}, GET /api/privileges) allow any authenticated user — regardless of their assigned permissions — to enumerate the complete list of system privileges and role definitions. An attacker with only a low-privilege account (e.g., a read-only operator) can retrieve the full privilege taxonomy of the server, including the names and assignments of all administrator-level capabilities. This information directly enables targeted privilege escalation attacks. --- Details Three handler methods in IamApi.java serve sensitive security metadata without performing any authorization check: File: yamcs-core/src/main/java/org/yamcs/http/api/IamApi.java By contrast, all write operations and user-management endpoints in the same file correctly enforce authorization. For example: The three vulnerable endpoints share the same ControlAccess protection requirement as the user-management endpoints but were…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cvw4-55pp-3hfq

  2. Revision 1 · created ·

    Published from osv record GHSA-cvw4-55pp-3hfq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55547

Advisory: Yamcs's Missing Authorization on Role and Privilege Enumeration Endpoints Allows Any Authenticated User to Disclose Full Security Configuration
IDs: CVE-2026-55547, GHSA-cvw4-55pp-3hfq
Record: https://patchnext.com/advisories/cve-2026-55547 (revision 2, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.yamcs:yamcs-core 5.13.2, 5.12.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.yamcs:yamcs-core: affected >= 5.13.0, <= 5.13.1; <= 5.12.7; fixed in 5.12.8, 5.13.2

## Suggested inspection (read-only)
- Maven org.yamcs:yamcs-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.yamcs:yamcs-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cvw4-55pp-3hfq (OSV record GHSA-cvw4-55pp-3hfq lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <5.12.8 (fixed))
- Verified: https://github.com/advisories/GHSA-cvw4-55pp-3hfq (GitHub-reviewed advisory GHSA-cvw4-55pp-3hfq lists affected ranges: Maven org.yamcs:yamcs-core >=5.13.0 =0 <=5.12.7)

Commands are suggestions: review each one before running it.

Loading voting…