Skip to content

← Actionable
Critical, CVSS 9.8amended

qwed-mcp has Unsafe SymPy parse_expr() Remote Code Execution via Unsanitized Math Expression Input

CVE-2026-55546GHSA-mw6r-2hvm-4rp2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (qwed-mcp 0.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI qwed-mcp

    Affected
    < 0.2.1
    Fixed in
    0.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-55546: 0.73% estimated exploitation activity in the next 30 days; percentile 54.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary verifymathexpression() in qwed-mcp v0.2.0 passes attacker-controlled strings directly to SymPy's parseexpr() without restricting globaldict or validating the expression's AST. Because parseexpr() internally calls eval() and Python automatically injects the current module's builtins when no explicit restriction is set, an attacker can embed arbitrary Python expressions — including import('os').system(...) — to execute OS commands in the context of the running process. Confirmed exploitation in a Docker container yields root-level arbitrary command execution with no authentication or special configuration required. Details The vulnerability resides in src/qwedmcp/engines/mathengine.py. The public function verifymathexpression(expression, claimedresult, operation) accepts both the expression and claimedresult arguments as raw strings and passes them — after a trivial ^ → substitution — to sympy.parsing.sympyparser.parseexpr(): localdict only adds math symbols to the evaluation…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mw6r-2hvm-4rp2

  2. Revision 2 · amended ·

    Amended from osv record GHSA-mw6r-2hvm-4rp2

  3. Revision 1 · created ·

    Published from ghsa record GHSA-mw6r-2hvm-4rp2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55546

Advisory: qwed-mcp has Unsafe SymPy `parse_expr()` Remote Code Execution via Unsanitized Math Expression Input
IDs: CVE-2026-55546, GHSA-mw6r-2hvm-4rp2
Record: https://patchnext.com/advisories/cve-2026-55546 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: qwed-mcp 0.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI qwed-mcp: affected < 0.2.1; fixed in 0.2.1

## Suggested inspection (read-only)
- `python -m pip show qwed-mcp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on qwed-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mw6r-2hvm-4rp2 (GitHub-reviewed advisory GHSA-mw6r-2hvm-4rp2 lists affected ranges: PyPI qwed-mcp >=0 <0.2.1)
- Verified: https://osv.dev/vulnerability/GHSA-mw6r-2hvm-4rp2 (OSV record GHSA-mw6r-2hvm-4rp2 lists affected ranges: PyPI qwed-mcp >=0 <0.2.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…