Yamcs's WebSocket subscription handlers omit the privilege checks their REST siblings enforce
CVE-2026-55545GHSA-fwww-cp23-7f5g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.yamcs:yamcs-core 5.13.2, 5.12.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.yamcs:yamcs-core
- Affected
- <= 5.12.7>= 5.13.0, <= 5.13.1
- Fixed in
- 5.12.8, 5.13.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fwww-cp23-7f5g lists affected ranges: Maven org.yamcs:yamcs-core >=0 =5.13.0 <5.13.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fwww-cp23-7f5g lists affected ranges: Maven org.yamcs:yamcs-core >=0 =5.13.0 <=5.13.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-55545: 0.45% estimated exploitation activity in the next 30 days; percentile 39.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Asset / scope: Yamcs 5.12.7 WebSocket topics (packets, algorithm-status, mdb-changes) Summary Several WebSocket subscription handlers do not perform the privilege check that their REST counterparts enforce, so a principal subscribing over WebSocket receives data the REST API would have scoped or denied. Root cause - packets (PacketsApi.subscribePackets) performs no ReadPacket check, while the REST siblings do (listPackets:128, streamPackets:256, subscribeContainers:538). A principal with a narrow ReadPacket scope receives the raw binary of all TM packets on the processor. - algorithm-status (ProcessingApi.subscribeAlgorithmStatus) performs no check, while REST getAlgorithmStatus enforces checkObjectPrivileges(ReadAlgorithm, ...) (:467). - mdb-changes (MdbOverrideApi.subscribeMdbChanges) performs no check, while base MDB reads require GetMissionDatabase. Remediation Bring each WebSocket subscription handler to parity with its REST sibling's privilege check (ReadPacket, ReadAlgorithm,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fwww-cp23-7f5g
- Revision 1 · created ·
Published from osv record GHSA-fwww-cp23-7f5g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55545 Advisory: Yamcs's WebSocket subscription handlers omit the privilege checks their REST siblings enforce IDs: CVE-2026-55545, GHSA-fwww-cp23-7f5g Record: https://patchnext.com/advisories/cve-2026-55545 (revision 2, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.yamcs:yamcs-core 5.13.2, 5.12.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.yamcs:yamcs-core: affected <= 5.12.7; >= 5.13.0, <= 5.13.1; fixed in 5.12.8, 5.13.2 ## Suggested inspection (read-only) - Maven org.yamcs:yamcs-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.yamcs:yamcs-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fwww-cp23-7f5g (OSV record GHSA-fwww-cp23-7f5g lists affected ranges: Maven org.yamcs:yamcs-core >=0 =5.13.0 <5.13.2 (fixed)) - Verified: https://github.com/advisories/GHSA-fwww-cp23-7f5g (GitHub-reviewed advisory GHSA-fwww-cp23-7f5g lists affected ranges: Maven org.yamcs:yamcs-core >=0 =5.13.0 <=5.13.1) Commands are suggestions: review each one before running it.
Loading voting…