Skip to content

← Actionable
High, CVSS 7.1

PraisonAI: [Path Traversal] agent tools escape the configured workspace via symlinks

CVE-2026-55540GHSA-ch89-h4r2-c8f8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.58), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-55540: 0.39% estimated exploitation activity in the next 30 days; percentile 33.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PraisonAI's praisonai.code tool wrappers (exported as CODETOOLS for agents) expose a workspace setting that the module itself treats as a path-traversal security boundary — readfile, writefile, applydiff, and searchreplace explicitly call ispathwithindirectory() and return "… is outside the workspace" on violations. That boundary is enforced unsoundly and inconsistently: 1. The containment helper uses os.path.abspath(), not realpath()/Path.resolve(). A symlink located inside the workspace whose target is outside has an abspath() that is still inside the workspace, so it passes the check while open() follows the link. This bypasses read, write, applydiff, and searchreplace (CWE-59). 2. listfiles() resolves path against the workspace but never calls the containment helper at all — ../ and absolute paths escape directly (CWE-22). 3. executecommand() takes a workspace argument documented "for security validation" but performs no cwd containment check; codeexecutecommand()…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ch89-h4r2-c8f8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55540

Advisory: PraisonAI: [Path Traversal] agent tools escape the configured workspace via symlinks
IDs: CVE-2026-55540, GHSA-ch89-h4r2-c8f8
Record: https://patchnext.com/advisories/cve-2026-55540 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.58. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected < 4.6.58; fixed in 4.6.58

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ch89-h4r2-c8f8 (GitHub-reviewed advisory GHSA-ch89-h4r2-c8f8 lists affected ranges: PyPI praisonai >=0 <4.6.58)

Commands are suggestions: review each one before running it.

Loading voting…