Skip to content

← Actionable
High, CVSS 8.2

praisonaiagents: AgentServer declares auth_token but never enforces it on any route

CVE-2026-55528GHSA-7g3p-92qq-8wvh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 1.6.58), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
EPSS
  • CVE-2026-55528: 0.49% estimated exploitation activity in the next 30 days; percentile 41.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Researcher: Kai Aizen — SnailSploit (@SnailSploit), Adversarial & Offensive Security Research Target: https://github.com/MervinPraison/PraisonAI --- Package: praisonaiagents on PyPI Affected version (empirically tested): 1.6.48 Component: praisonaiagents.server.AgentServer (the bundled HTTP / SSE server) --- TL;DR AgentServer.ServerConfig advertises an authtoken: Optional[str] = None field that operators set when they want to lock down the server. The GET /info endpoint even displays it back as "authtoken": "" — strongly implying the value is wired into request authentication. It isn't. AgentServer.createapp never reads authtoken, never adds an authentication middleware, and never decorates any route with a dependency that checks it. Every route — /info, /publish, /events, /health — accepts unauthenticated requests regardless of whether authtoken is configured. The same package contains a sibling server, praisonaiagents.ui.a2a.A2A, written by the same developer, which implements the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7g3p-92qq-8wvh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55528

Advisory: praisonaiagents: AgentServer declares auth_token but never enforces it on any route
IDs: CVE-2026-55528, GHSA-7g3p-92qq-8wvh
Record: https://patchnext.com/advisories/cve-2026-55528 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 1.6.58. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonaiagents: affected < 1.6.58; fixed in 1.6.58

## Suggested inspection (read-only)
- `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonaiagents.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7g3p-92qq-8wvh (GitHub-reviewed advisory GHSA-7g3p-92qq-8wvh lists affected ranges: PyPI praisonaiagents >=0 <1.6.58)

Commands are suggestions: review each one before running it.

Loading voting…