Skip to content

← Actionable
Unrated

Snipe-IT has Improper Authorization in File Deletion (IDOR)

CVE-2026-55519GHSA-x667-r589-43m7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (snipe/snipe-it 8.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-55519: 0.37% estimated exploitation activity in the next 30 days; percentile 30.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability was identified in Snipe-IT v8.4.0 (build 21280-g91a95dbc6) that allows any authenticated user with generic asset edit permissions to delete files attached to any asset in the system, regardless of ownership or company assignment. This constitutes an Insecure Direct Object Reference (IDOR) vulnerability caused by a class-level authorization check in the file deletion endpoint, where an instance-level check is required. The vulnerability exists in both the web and API controllers, affecting all Snipe-IT installations running version 8.4.0 and potentially earlier versions. Patches Patched in https://github.com/grokability/snipe-it/commit/8bc7d50e35d93eee5a0d48b4923e497937cf93fd

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x667-r589-43m7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55519

Advisory: Snipe-IT has Improper Authorization in File Deletion (IDOR)
IDs: CVE-2026-55519, GHSA-x667-r589-43m7
Record: https://patchnext.com/advisories/cve-2026-55519 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: snipe/snipe-it 8.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist snipe/snipe-it: affected <= 8.4.0; fixed in 8.4.1

## Suggested inspection (read-only)
- Packagist snipe/snipe-it: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on snipe/snipe-it.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x667-r589-43m7 (GitHub-reviewed advisory GHSA-x667-r589-43m7 lists affected ranges: Packagist snipe/snipe-it >=0 <=8.4.0)

Commands are suggestions: review each one before running it.

Loading voting…