Skip to content

← Actionable
Critical, CVSS 9.6

Avo: Missing Authorization in Avo Association Attach Endpoint Allows Unauthorized Relationship Manipulation and Privilege Escalation

CVE-2026-55518GHSA-8fq9-273g-6mrg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (avo 4.0.0.beta.51, 3.32.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems avo

    Affected
    <= 3.32.0>= 4.0.0.beta.1, < 4.0.0.beta.51
    Fixed in
    3.32.1, 4.0.0.beta.51

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-55518: 0.41% estimated exploitation activity in the next 30 days; percentile 35.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A critical missing authorization flaw exists in Avo's association attach workflow. The UI and GET /resources/:resource/:id/:related/new path can check attach<association?, but the actual write endpoint, POST /resources/:resource/:id/:related, does not run the same authorization check before mutating the association. As a result, an authenticated low-privileged Avo user can bypass hidden/disabled attach controls and directly attach related records to a parent record by sending a crafted POST request. In applications where associations represent teams, tenants, roles, projects, users, memberships, ownership, or other authorization-bearing relationships, this can lead to privilege escalation and cross-tenant data exposure. Details The association attach route writes relationships through Avo::AssociationsController#create: The controller registers an attach authorization callback only for new, not for create: The new action is only the form-rendering step. The actual mutation…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8fq9-273g-6mrg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55518

Advisory: Avo: Missing Authorization in Avo Association Attach Endpoint Allows Unauthorized Relationship Manipulation and Privilege Escalation
IDs: CVE-2026-55518, GHSA-8fq9-273g-6mrg
Record: https://patchnext.com/advisories/cve-2026-55518 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: avo 4.0.0.beta.51, 3.32.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems avo: affected <= 3.32.0; >= 4.0.0.beta.1, < 4.0.0.beta.51; fixed in 3.32.1, 4.0.0.beta.51

## Suggested inspection (read-only)
- RubyGems avo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on avo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8fq9-273g-6mrg (GitHub-reviewed advisory GHSA-8fq9-273g-6mrg lists affected ranges: RubyGems avo >=0 =4.0.0.beta.1 <4.0.0.beta.51)

Commands are suggestions: review each one before running it.

Loading voting…