Skip to content

← Actionable
High, CVSS 8.8

WsgiDAV MySQL provider has a blind SQL injection

CVE-2026-55509GHSA-p6gw-4frg-j7jw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wsgidav 4.3.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wsgidav

    Affected
    <= 4.3.4
    Fixed in
    4.3.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-55509: 0.51% estimated exploitation activity in the next 30 days; percentile 43.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The sample MySQLBrowserProvider builds its SQL queries by concatenating strings, and the record key from the request URL goes straight into the WHERE clause with no escaping. Any user who can reach a share backed by this provider can inject SQL through the URL. Since these read shares are commonly published without authentication, an anonymous attacker can read arbitrary data from the backing database. Confirmed locally with a boolean oracle and full data extraction. Note: The MySQLBrowserProvider module is only provided as an example for WsgiDAV and not enabled by default. Installations that do not explicitly activate the module in their configuration are not affected by this vulnerability. Details A path like /db/users/1 is split into a table name and a key. The table name is validated against the real table list, but the key is dropped directly into the query. For the configured table the resulting statement is SELECT id FROM testdb.users WHERE id = '<key', so a single…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p6gw-4frg-j7jw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55509

Advisory: WsgiDAV MySQL provider has a blind SQL injection
IDs: CVE-2026-55509, GHSA-p6gw-4frg-j7jw
Record: https://patchnext.com/advisories/cve-2026-55509 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wsgidav 4.3.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wsgidav: affected <= 4.3.4; fixed in 4.3.5

## Suggested inspection (read-only)
- `python -m pip show wsgidav`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wsgidav.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p6gw-4frg-j7jw (GitHub-reviewed advisory GHSA-p6gw-4frg-j7jw lists affected ranges: PyPI wsgidav >=0 <=4.3.4)

Commands are suggestions: review each one before running it.

Loading voting…