Skip to content

← Actionable
High, CVSS 7.3amended

9router: Login brute-force protection bypass via spoofed X-Forwarded-For header

CVE-2026-55501GHSA-7cfm-pqrj-xgq7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (9router 0.4.77), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm 9router

    Affected
    <= 0.4.71
    Fixed in
    0.4.77

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-55501: 0.38% estimated exploitation activity in the next 30 days; percentile 31.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The 9router dashboard login rate limiter derives the client identity from the attacker-controlled X-Forwarded-For HTTP header. When 9router is directly exposed, or deployed behind a reverse proxy that does not overwrite untrusted forwarding headers, a remote attacker can rotate the X-Forwarded-For value on each login attempt and receive a fresh rate-limit bucket every time. This bypasses the dashboard brute-force protection and makes the login lockout mechanism ineffective. Details | Component | File | Note | | ---------------------------- | --------------------------------- | --------------------------------------------------------------------------- | | Dashboard login rate limiter | src/lib/auth/loginLimiter.js | Uses X-Forwarded-For as the client identity without a trusted-proxy check | | Dashboard login route | src/app/api/auth/login/route.js | Calls checkLock() and recordFail() using the spoofable client identity | Vulnerable Code src/lib/auth/loginLimiter.js: The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7cfm-pqrj-xgq7

  2. Revision 1 · created ·

    Published from osv record GHSA-7cfm-pqrj-xgq7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55501

Advisory: 9router: Login brute-force protection bypass via spoofed X-Forwarded-For header
IDs: CVE-2026-55501, GHSA-7cfm-pqrj-xgq7
Record: https://patchnext.com/advisories/cve-2026-55501 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: 9router 0.4.77. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm 9router: affected <= 0.4.71; fixed in 0.4.77

## Suggested inspection (read-only)
- `npm ls 9router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on 9router.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7cfm-pqrj-xgq7 (OSV record GHSA-7cfm-pqrj-xgq7 lists affected ranges: npm 9router >=0 <0.4.77 (fixed))
- Verified: https://github.com/advisories/GHSA-7cfm-pqrj-xgq7 (GitHub-reviewed advisory GHSA-7cfm-pqrj-xgq7 lists affected ranges: npm 9router >=0 <=0.4.71)

Commands are suggestions: review each one before running it.

Loading voting…