Skip to content

← Actionable
Unrated

Snipe-IT has a path traversal vulnerability via CSV import image field

CVE-2026-55469GHSA-xr9m-gphc-9p63

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (snipe/snipe-it 8.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-55469: 0.59% estimated exploitation activity in the next 30 days; percentile 48.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user holding the import and assets.update permissions can delete arbitrary files on the server filesystem by injecting a path traversal string into an asset's image field via CSV import, then triggering the image deletion feature.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xr9m-gphc-9p63

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55469

Advisory: Snipe-IT has a path traversal vulnerability via CSV import `image` field
IDs: CVE-2026-55469, GHSA-xr9m-gphc-9p63
Record: https://patchnext.com/advisories/cve-2026-55469 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: snipe/snipe-it 8.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist snipe/snipe-it: affected <= 8.6.1; fixed in 8.6.2

## Suggested inspection (read-only)
- Packagist snipe/snipe-it: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on snipe/snipe-it.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xr9m-gphc-9p63 (GitHub-reviewed advisory GHSA-xr9m-gphc-9p63 lists affected ranges: Packagist snipe/snipe-it >=0 <=8.6.1)

Commands are suggestions: review each one before running it.

Loading voting…