Skip to content

← Actionable
Low, CVSS 2.9amended

Caddy has an RFC 7230 §6.1 compliance issue / Hop-by-hop headers that leak through

CVE-2026-55458GHSA-8qx7-j2v2-x6q5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/caddyserver/caddy/v2 2.11.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

AI Disclosure This vulnerability was discovered via deepseek-v4-pro[1m] for finding potential vulnerabilities / inconsistencies in the code base. I made the AI check if Caddy is compliant with various RFCs, incl. 7230. I also used it to help write the PoC, since it was honestly much faster than writing it by hand. I also let it write parts of this advisory text for brevity's sake, but had to rewrite half of it by hand.

Summary Caddy's reverse proxy fails to strip RFC 7230 hop-by-hop headers from upstream responses when handling WebSocket upgrades (HTTP 101 Switching Protocols). Headers including `Alt-Svc`, `Keep-Alive`, `Proxy-Authenticate`, `Transfer-Encoding`, or `Trailer`, which Caddy actually correctly strips for normal HTTP responses, pass through unfiltered to the client during protocol upgrades. An upstream that sets these headers (intentionally or otherwise) can inject them into client responses, enabling connection hijacking via `Alt-Svc`, cookie injection via…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-8qx7-j2v2-x6q5

  2. Revision 1 · created ·

    Published from ghsa record GHSA-8qx7-j2v2-x6q5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55458

Advisory: Caddy has an RFC 7230 §6.1 compliance issue / Hop-by-hop headers that leak through
IDs: CVE-2026-55458, GHSA-8qx7-j2v2-x6q5
Record: https://patchnext.com/advisories/cve-2026-55458 (revision 2, source checked 29 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/caddyserver/caddy/v2 2.11.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/caddyserver/caddy/v2: affected < 2.11.5; fixed in 2.11.5

## Suggested inspection (read-only)
- Go github.com/caddyserver/caddy/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/caddyserver/caddy/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8qx7-j2v2-x6q5 (GitHub-reviewed advisory GHSA-8qx7-j2v2-x6q5 lists affected ranges: Go github.com/caddyserver/caddy/v2 >=0 <=2.11.4)
- Verified: https://osv.dev/vulnerability/GHSA-8qx7-j2v2-x6q5 (OSV record GHSA-8qx7-j2v2-x6q5 lists affected ranges: Go github.com/caddyserver/caddy/v2 >=0 <2.11.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…