gettext-converter: Prototype pollution in js2i18next() via crafted translation keys
CVE-2026-55451GHSA-f4jp-rw7w-ccwg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gettext-converter 1.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.3.3
- Fixed in
- 1.3.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f4jp-rw7w-ccwg lists affected ranges: npm gettext-converter >=0 <1.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-55451: 0.57% estimated exploitation activity in the next 30 days; percentile 47.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact js2i18next() is vulnerable to prototype pollution. When converting translations, it splits nested keys on the key separator (default ##) and uses each segment as a dynamic object key while building the output object. A key whose segment is proto (e.g. proto##gcPolluted) causes the converter to resolve Object.prototype as the nested write target and assign the translated value onto it, polluting Object.prototype for the whole runtime. Any application that converts translation data (PO / i18next JS objects) originating from an untrusted or user-controlled source is affected. Prototype pollution can lead to denial of service and, depending on the surrounding application, may enable further attacks. Patches Fixed in gettext-converter@1.3.3. Key segments equal to proto, constructor, or prototype are now rejected before being used as dynamic object keys. Workarounds Upgrade to 1.3.3. If upgrading is not immediately possible, sanitize/validate translation keys before passing them to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f4jp-rw7w-ccwg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55451 Advisory: gettext-converter: Prototype pollution in js2i18next() via crafted translation keys IDs: CVE-2026-55451, GHSA-f4jp-rw7w-ccwg Record: https://patchnext.com/advisories/cve-2026-55451 (revision 1, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gettext-converter 1.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm gettext-converter: affected < 1.3.3; fixed in 1.3.3 ## Suggested inspection (read-only) - `npm ls gettext-converter --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gettext-converter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f4jp-rw7w-ccwg (GitHub-reviewed advisory GHSA-f4jp-rw7w-ccwg lists affected ranges: npm gettext-converter >=0 <1.3.3) Commands are suggestions: review each one before running it.
Loading voting…