Skip to content

← Actionable
Critical, CVSS 9.3amended

Langflow: Unauthenticated file upload leads to DoS (space exhaustion) and information leak

CVE-2026-55450GHSA-x223-p2gf-v735

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langflow

    Affected
    < 1.9.1
    Fixed in
    1.9.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:H
EPSS
  • CVE-2026-55450: 1.19% estimated exploitation activity in the next 30 days; percentile 68.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Unauthenticated users can upload any amount of data to the server without any limitations. No need for any prior knowledge, only network access to Langflow. This can lead to space exhaustion on the server. In adition, in the response, the absolute path of the uploaded file is reported to the attacker, which is an information leak that can assist in chaining other primitives. Tested on commit 2d67402b1dbaefcbce85a244d4a6cd5e4bda1cfe Details Code is in langflow/api/v1/endpoints.py: As can be seen above, there is no authentication. There is not validation over flowid as well, unlike other endpoints: Function saveuploadedfile saves the file to local file-system. Suggested fix: 1. Add authentication to route. 2. Only return relative path or filename. PoC PoC: Example: Impact 1. Space exhaustion on server that can lead to Denial-of-Service. 2. Information leak - leakage of absolute path of langflow's cache directory in server. Patches Fixed in 1.9.1 via PR #12831. The deprecated…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x223-p2gf-v735

  2. Revision 2 · amended ·

    Amended from osv record GHSA-x223-p2gf-v735

  3. Revision 1 · created ·

    Published from ghsa record GHSA-x223-p2gf-v735

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55450

Advisory: Langflow: Unauthenticated file upload leads to DoS (space exhaustion) and information leak
IDs: CVE-2026-55450, GHSA-x223-p2gf-v735
Record: https://patchnext.com/advisories/cve-2026-55450 (revision 3, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langflow 1.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langflow: affected < 1.9.1; fixed in 1.9.1

## Suggested inspection (read-only)
- `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x223-p2gf-v735 (GitHub-reviewed advisory GHSA-x223-p2gf-v735 lists affected ranges: PyPI langflow >=0 <1.9.1)
- Verified: https://osv.dev/vulnerability/GHSA-x223-p2gf-v735 (OSV record GHSA-x223-p2gf-v735 lists affected ranges: PyPI langflow >=0 <1.9.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…