Mise's local credential_command executes untrusted config
CVE-2026-55448GHSA-29hf-rm4x-xxph
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mise 2026.6.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io mise
- Affected
- >= 2026.3.15, < 2026.6.4
- Fixed in
- 2026.6.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-29hf-rm4x-xxph lists affected ranges: crates.io mise >=2026.3.15 <2026.6.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-29hf-rm4x-xxph lists affected ranges: crates.io mise >=2026.3.15 <2026.6.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-55448: 0.20% estimated exploitation activity in the next 30 days; percentile 9.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary `mise` loads `github.credential_command` from local project config before any trust decision, then executes that value with `sh -c` when resolving a GitHub token. An attacker who can place a `.mise.toml` in a repository can execute arbitrary shell commands when the victim runs a GitHub-related mise command and no higher-priority GitHub token environment variable is set. The current command-execution path is `github.credential_command`. I confirmed in Docker that the setting is exploitable on `v2026.3.15` and `v2026.3.17`, while `v2026.3.14` rejects it as an unknown field. This report does not depend on the separate trust-bypass issue because the sink is reached directly from `[settings.github]`.
Details The vulnerable load order is: 1. `Settings::try_get()` preloads settings from local config files. 2.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-29hf-rm4x-xxph
- Revision 2 · amended ·
Amended from ghsa record GHSA-29hf-rm4x-xxph
- Revision 1 · created ·
Published from ghsa record GHSA-29hf-rm4x-xxph
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55448 Advisory: Mise's local credential_command executes untrusted config IDs: CVE-2026-55448, GHSA-29hf-rm4x-xxph Record: https://patchnext.com/advisories/cve-2026-55448 (revision 3, source checked 4 Nov 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mise 2026.6.4. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io mise: affected >= 2026.3.15, < 2026.6.4; fixed in 2026.6.4 ## Suggested inspection (read-only) - crates.io mise: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-29hf-rm4x-xxph (GitHub-reviewed advisory GHSA-29hf-rm4x-xxph lists affected ranges: crates.io mise >=2026.3.15 <2026.6.4) - Verified: https://osv.dev/vulnerability/GHSA-29hf-rm4x-xxph (OSV record GHSA-29hf-rm4x-xxph lists affected ranges: crates.io mise >=2026.3.15 <2026.6.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…