Langflow: Unauthenticated DoS through multipart form boundary file upload
CVE-2026-55446GHSA-qwqc-p3q8-wcg9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.0.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langflow
- Affected
- < 1.0.19
- Fixed in
- 1.0.19
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qwqc-p3q8-wcg9 lists affected ranges: PyPI langflow >=0 <1.0.19 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qwqc-p3q8-wcg9 lists affected ranges: PyPI langflow >=0 <1.0.19
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-55446: 0.58% estimated exploitation activity in the next 30 days; percentile 47.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An attacker can send a /api/v1/files/upload/ request without any authentication token/cookies and abuse a very long multipart form boundary to make the langflow app unusable for all users for an indefinite amount of time. Details https://github.com/langflow-ai/langflow/blob/v1.0.18/src/backend/base/langflow/api/v1/files.py#L40 The file upload function will try to process the multipart form data even if it is malformed and contains a payload such as an extremely large amount of hyphens after the boundary. It also does not do the authentication check before trying to process this data so an unauthenticated attacker can perform this as well as authenticated users. Additionally, an attacker doesn't even need to know a valid UUID of a flow to send this request because the server will still try to process the large boundary even with any random value in place of the flow ID. PoC An attacker makes this request to upload a file without valid authentication information or a valid flow…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qwqc-p3q8-wcg9
- Revision 1 · created ·
Published from osv record GHSA-qwqc-p3q8-wcg9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55446 Advisory: Langflow: Unauthenticated DoS through multipart form boundary file upload IDs: CVE-2026-55446, GHSA-qwqc-p3q8-wcg9 Record: https://patchnext.com/advisories/cve-2026-55446 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langflow 1.0.19. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langflow: affected < 1.0.19; fixed in 1.0.19 ## Suggested inspection (read-only) - `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qwqc-p3q8-wcg9 (OSV record GHSA-qwqc-p3q8-wcg9 lists affected ranges: PyPI langflow >=0 <1.0.19 (fixed)) - Verified: https://github.com/advisories/GHSA-qwqc-p3q8-wcg9 (GitHub-reviewed advisory GHSA-qwqc-p3q8-wcg9 lists affected ranges: PyPI langflow >=0 <1.0.19) Commands are suggestions: review each one before running it.
Loading voting…