Skip to content

← Actionable
Medium, CVSS 5.4

Coder vulnerable to stored HTML injection via workspace agent logs in AgentLogLine component

CVE-2026-55437GHSA-7qw2-f75v-62f7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/coder/coder/v2 2.34.2, 2.33.8, 2.32.7, 2.29.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/coder/coder/v2

    Affected
    >= 2.34.0, < 2.34.2>= 2.33.0, < 2.33.8>= 2.30.0, < 2.32.7< 2.29.17
    Fixed in
    2.33.8, 2.29.17, 2.34.2, 2.32.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-55437: 0.32% estimated exploitation activity in the next 30 days; percentile 24.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The AgentLogLine dashboard component instantiated ansi-to-html without escapeXML: true and inserted the result via dangerouslySetInnerHTML so HTML embedded in workspace agent log lines was rendered as live markup. Server-side sanitization did not neutralize HTML metacharacters. Note: Exploitation requires a victim to view attacker-controlled agent logs in the dashboard. Impact A user who could run a workspace could emit arbitrary HTML into agent logs; when another user, including an administrator, viewed the workspace page, it rendered in their session. Content Security Policy blocked inline scripts but an attacker could still inject a meta refresh redirect, style rules for UI redressing or CSS-based exfiltration or external img beacons. This required workspace-owner access and a victim viewing the page. Patches The fix enables escapeXML: true so HTML metacharacters are escaped before DOM insertion. The fix was backported to all supported release lines: | Release line |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7qw2-f75v-62f7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55437

Advisory: Coder vulnerable to stored HTML injection via workspace agent logs in AgentLogLine component
IDs: CVE-2026-55437, GHSA-7qw2-f75v-62f7
Record: https://patchnext.com/advisories/cve-2026-55437 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/coder/coder/v2 2.34.2, 2.33.8, 2.32.7, 2.29.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/coder/coder/v2: affected >= 2.34.0, < 2.34.2; >= 2.33.0, < 2.33.8; >= 2.30.0, < 2.32.7; < 2.29.17; fixed in 2.33.8, 2.29.17, 2.34.2, 2.32.7

## Suggested inspection (read-only)
- Go github.com/coder/coder/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/coder/coder/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7qw2-f75v-62f7 (GitHub-reviewed advisory GHSA-7qw2-f75v-62f7 lists affected ranges: Go github.com/coder/coder/v2 >=2.34.0 =2.33.0 =2.30.0 =0 <2.29.17)

Commands are suggestions: review each one before running it.

Loading voting…