Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator
CVE-2026-55428GHSA-wrq8-fcv5-8hvp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/coder/coder/v2 2.34.2, 2.33.8, 2.32.7, 2.29.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.34.0, < 2.34.2>= 2.33.0, < 2.33.8>= 2.30.0, < 2.32.7< 2.29.17
- Fixed in
- 2.33.8, 2.29.17, 2.34.2, 2.32.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wrq8-fcv5-8hvp lists affected ranges: Go github.com/coder/coder/v2 >=2.34.0 =2.33.0 =2.30.0 =0 <2.29.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-55428: 0.40% estimated exploitation activity in the next 30 days; percentile 34.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The tailnet coordinator validates that an agent's Addresses derive from its authenticated UUID but applies no equivalent check to AllowedIPs. The coordinator forwards agent-supplied AllowedIPs verbatim to tunnel peers which install them into the WireGuard peer configuration. Impact A malicious workspace agent can advertise arbitrary AllowedIPs prefixes including another agent's tailnet address. Coder's ServerTailnet routes to agents by tailnet IP so an agent that claims a victim's prefix can intercept web terminal and workspace app traffic and serve spoofed content. Exploitation requires an authenticated user with a running workspace and a modified agent binary. Patches The fix validates each AllowedIPs prefix against the authenticating agent's UUID just like Addresses. The fix was backported to all supported release lines: | Release line | Patched version | |---|---| | 2.34 | v2.34.2 | | 2.33 | v2.33.8 | | 2.32 | v2.32.7 | | 2.29 (ESR) | v2.29.17 | Workarounds Operators who…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wrq8-fcv5-8hvp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55428 Advisory: Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator IDs: CVE-2026-55428, GHSA-wrq8-fcv5-8hvp Record: https://patchnext.com/advisories/cve-2026-55428 (revision 1, source checked 26 Oct 2026, 15:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/coder/coder/v2 2.34.2, 2.33.8, 2.32.7, 2.29.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/coder/coder/v2: affected >= 2.34.0, < 2.34.2; >= 2.33.0, < 2.33.8; >= 2.30.0, < 2.32.7; < 2.29.17; fixed in 2.33.8, 2.29.17, 2.34.2, 2.32.7 ## Suggested inspection (read-only) - Go github.com/coder/coder/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/coder/coder/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wrq8-fcv5-8hvp (GitHub-reviewed advisory GHSA-wrq8-fcv5-8hvp lists affected ranges: Go github.com/coder/coder/v2 >=2.34.0 =2.33.0 =2.30.0 =0 <2.29.17) Commands are suggestions: review each one before running it.
Loading voting…