Skip to content

← Actionable
Medium, CVSS 5.3

reachy_mini Allows Unrestricted Upload of File with Dangerous Type

CVE-2026-55419GHSA-m2pc-3q4q-w6jr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (reachy-mini 1.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-55419: 0.48% estimated exploitation activity in the next 30 days; percentile 41.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Reachy Mini daemon exposes the “/api/media/sounds/upload” endpoint without authentication and file validation mechanisms. An attacker can use this endpoint to upload malicious files into the file system that will propagate in future attacks. Compromise Chain: Unauthenticated to Full Root Access This issue is part of a full compromise chain allowing an unauthenticated user to gain root access on the Reachy’s operating system: 1. Unrestricted File Upload in Media Sounds Upload API \<= current finding 2. Bluetooth Authentication Bypass 3. Bluetooth Directory Traversal Description The root cause of the issue is at the handler located in “src/daemon/app/routers/media.py” file at the “upload\sound” method: This endpoint lacks multiple defence mechanisms: 1. No authentication mechanism. 2. No file extension validation. 3. No file content/size validation. Additionally, the daemon is bound to the 0.0.0.0 network interfaces (a.k.a. all network interfaces) by default along with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m2pc-3q4q-w6jr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55419

Advisory: reachy_mini Allows Unrestricted Upload of File with Dangerous Type
IDs: CVE-2026-55419, GHSA-m2pc-3q4q-w6jr
Record: https://patchnext.com/advisories/cve-2026-55419 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: reachy-mini 1.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI reachy-mini: affected < 1.8.2; fixed in 1.8.2

## Suggested inspection (read-only)
- `python -m pip show reachy-mini`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on reachy-mini.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m2pc-3q4q-w6jr (GitHub-reviewed advisory GHSA-m2pc-3q4q-w6jr lists affected ranges: PyPI reachy-mini >=0 <1.8.2)

Commands are suggestions: review each one before running it.

Loading voting…