Skip to content

← Actionable
High, CVSS 8.8

Pimcore: SQL Injection in Custom Reports via Malicious Report Configuration

CVE-2026-55416GHSA-23rh-xw42-fq82

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 2026.1.6, 12.3.10, 11.5.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist pimcore/pimcore

    Affected
    >= 2026.1.0, < 2026.1.6>= 12.0.0-RC1, < 12.3.10< 11.5.19
    Fixed in
    2026.1.6, 12.3.10, 11.5.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-55416: 0.65% estimated exploitation activity in the next 30 days; percentile 51.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Security Advisory: SQL Injection in Custom Reports via Malicious Report Configuration

Summary

Impact A SQL injection vulnerability exists in the Custom Reports bundle (`bundles/CustomReportsBundle/src/Tool/Adapter/Sql.php:84-135`). An authenticated attacker with `reports_config` permission can inject arbitrary SQL via the report configuration fields (`sql`, `from`, `where`, `groupby`), which are directly concatenated into SQL queries without parameterization. The only protection is a regex blacklist that checks for `ALTER|CREATE|DROP|RENAME|TRUNCATE|UPDATE|DELETE` keywords, which is trivially bypassable — it does not block `INSERT`, `UNION SELECT`, `LOAD_FILE()`, `INTO OUTFILE`, stacked queries, subqueries, or MySQL comment injection (`/*!*/`). Exploitation allows reading, modifying, or deleting all data in the database, leading to complete data compromise. Additionally, the LIMIT clause at line 51 directly interpolates `$offset` and `$limit` without integer casting,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record GHSA-23rh-xw42-fq82

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55416

Advisory: Pimcore: SQL Injection in Custom Reports via Malicious Report Configuration
IDs: CVE-2026-55416, GHSA-23rh-xw42-fq82
Record: https://patchnext.com/advisories/cve-2026-55416 (revision 1, source checked 23 Oct 2026, 22:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 2026.1.6, 12.3.10, 11.5.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pimcore/pimcore: affected >= 2026.1.0, < 2026.1.6; >= 12.0.0-RC1, < 12.3.10; < 11.5.19; fixed in 2026.1.6, 12.3.10, 11.5.19

## Suggested inspection (read-only)
- Packagist pimcore/pimcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pimcore/pimcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-23rh-xw42-fq82 (OSV record GHSA-23rh-xw42-fq82 lists affected ranges: Packagist pimcore/pimcore >=2026.1.0 =12.0.0-RC1 =0 <11.5.19 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…