datamodel-code-generator vulnerable to code injection via x-python-import / customTypePath in generated import statements
CVE-2026-55415GHSA-5578-w22f-pfx9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (datamodel-code-generator 0.64.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.11.6, <= 0.63.0
- Fixed in
- 0.64.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5578-w22f-pfx9 lists affected ranges: PyPI datamodel-code-generator >=0.11.6 <=0.63.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-55415: 0.49% estimated exploitation activity in the next 30 days; percentile 42.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A malicious input schema (OpenAPI / JSON Schema) can execute arbitrary Python code on the machine that imports the generated model. The x-python-import and customTypePath schema extensions flow, unsanitized, into the import statements datamodel-code-generator emits. A newline embedded in the extension value breaks out of the from … import … line and injects an attacker-controlled statement at module scope, which runs at import time. This is an unauthenticated, schema-content–driven remote code execution against any consumer of the generated code (e.g. arbitrary file read,the PoC exfiltrates /etc/passwd). It survives the v0.61.0 security release that fixed the related x-python-type, defaultfactory, GraphQL-union-description, and validators sinks those fixes did not cover this sibling path. Details The sink is Import.fromfullpath and Imports.createline: - src/datamodelcodegenerator/imports.py:35 — fromfullpath() only does classpath.split(".") and preserves every other…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5578-w22f-pfx9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55415 Advisory: datamodel-code-generator vulnerable to code injection via `x-python-import` / `customTypePath` in generated import statements IDs: CVE-2026-55415, GHSA-5578-w22f-pfx9 Record: https://patchnext.com/advisories/cve-2026-55415 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: datamodel-code-generator 0.64.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI datamodel-code-generator: affected >= 0.11.6, <= 0.63.0; fixed in 0.64.0 ## Suggested inspection (read-only) - `python -m pip show datamodel-code-generator`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on datamodel-code-generator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5578-w22f-pfx9 (GitHub-reviewed advisory GHSA-5578-w22f-pfx9 lists affected ranges: PyPI datamodel-code-generator >=0.11.6 <=0.63.0) Commands are suggestions: review each one before running it.
Loading voting…