Skip to content

← Actionable
High, CVSS 7.6amended

Filament: Disabled RichEditor field state can be used for XSS

CVE-2026-55409GHSA-m9cv-24rx-8mv7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (filament/forms 3.3.53), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-55409: 0.28% estimated exploitation activity in the next 30 days; percentile 21.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Filament v3, a disabled `RichEditor` field rendered its raw state without sanitizing HTML. Where the data stored in this field's state isn't sanitized already when the form state was filled, an attacker could plant malicious HTML or JavaScript and achieve XSS that executes for users who view the form. Please note that Filament v4 and above does not use the same mechanism for rendering a disabled `RichEditor` so this advisory does not apply.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-m9cv-24rx-8mv7

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-m9cv-24rx-8mv7

  3. Revision 1 · created ·

    Published from ghsa record GHSA-m9cv-24rx-8mv7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55409

Advisory: Filament: Disabled RichEditor field state can be used for XSS
IDs: CVE-2026-55409, GHSA-m9cv-24rx-8mv7
Record: https://patchnext.com/advisories/cve-2026-55409 (revision 3, source checked 4 Nov 2026, 06:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: filament/forms 3.3.53. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist filament/forms: affected >= 3.0.0, < 3.3.53; fixed in 3.3.53

## Suggested inspection (read-only)
- Packagist filament/forms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on filament/forms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m9cv-24rx-8mv7 (GitHub-reviewed advisory GHSA-m9cv-24rx-8mv7 lists affected ranges: Packagist filament/forms >=3.0.0 <=3.3.52)
- Verified: https://osv.dev/vulnerability/GHSA-m9cv-24rx-8mv7 (OSV record GHSA-m9cv-24rx-8mv7 lists affected ranges: Packagist filament/forms >=3.0.0 <3.3.53 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…