datamodel-code-generator: Authorization / request headers leaked to cross-origin redirect target when fetching remote schemas
CVE-2026-55403GHSA-r5vv-ff45-prp2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (datamodel-code-generator 0.63.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 0.62.0
- Fixed in
- 0.63.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r5vv-ff45-prp2 lists affected ranges: PyPI datamodel-code-generator >=0 <=0.62.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-55403: 0.34% estimated exploitation activity in the next 30 days; percentile 27.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When datamodel-code-generator fetches a remote schema and follows an HTTP redirect, it re-sends the original request headers, including any Authorization header, to the redirect target even when the redirect changes origin (host/port/scheme). Credentials that an operator scoped to a trusted schema host are therefore forwarded to an attacker-controlled or otherwise different host, leaking them. Details In src/datamodelcodegenerator/http.py, getbody() follows redirects manually and re-issues each hop with the same headers argument, with no check that the origin is unchanged: Browsers and HTTP clients such as requests/httpx strip Authorization when a redirect crosses origin; here it is preserved unconditionally. Headers are operator-supplied via --http-headers (and credentials can also arrive through --url userinfo), so a redirect from the trusted host to any other host discloses them. PoC Self-contained reproducer:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r5vv-ff45-prp2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55403 Advisory: datamodel-code-generator: Authorization / request headers leaked to cross-origin redirect target when fetching remote schemas IDs: CVE-2026-55403, GHSA-r5vv-ff45-prp2 Record: https://patchnext.com/advisories/cve-2026-55403 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: datamodel-code-generator 0.63.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI datamodel-code-generator: affected <= 0.62.0; fixed in 0.63.0 ## Suggested inspection (read-only) - `python -m pip show datamodel-code-generator`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on datamodel-code-generator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r5vv-ff45-prp2 (GitHub-reviewed advisory GHSA-r5vv-ff45-prp2 lists affected ranges: PyPI datamodel-code-generator >=0 <=0.62.0) Commands are suggestions: review each one before running it.
Loading voting…