Skip to content

← Actionable
High, CVSS 7.5

datamodel-code-generator vulnerable to arbitrary local file read via XSD schemaLocation (xs:include/xs:import) path traversal, with no remote-ref gate

CVE-2026-55390GHSA-442q-2j6p-642g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (datamodel-code-generator 0.62.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-55390: 0.55% estimated exploitation activity in the next 30 days; percentile 46.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When generating models from an XML Schema (--input-file-type xmlschema), datamodel-code-generator resolves <xs:include, <xs:import, <xs:redefine, and <xs:override schemaLocation attributes against the source directory and reads the target with no restriction to the input/base directory. An attacker who controls the input XSD can read arbitrary files via ../ traversal or an absolute path, and the included schema's contents (type names, restrictions, enumerations) are folded into the generated output. Unlike the JSON-Schema $ref path, there is no allowremoterefs control for XSD, so --no-allow-remote-refs does not mitigate it. This is an unauthenticated path-traversal / information-disclosure issue reachable in the default configuration. Details The XSD parser walks include-style children and reads each schemaLocation with only an isfile() check (src/datamodelcodegenerator/parser/xmlschema.py): schemalocation is attacker-controlled and readxmltext does path.readbytes(). Because…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-442q-2j6p-642g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55390

Advisory: datamodel-code-generator vulnerable to arbitrary local file read via XSD `schemaLocation` (`xs:include`/`xs:import`) path traversal, with no remote-ref gate
IDs: CVE-2026-55390, GHSA-442q-2j6p-642g
Record: https://patchnext.com/advisories/cve-2026-55390 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: datamodel-code-generator 0.62.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI datamodel-code-generator: affected >= 0.59.0, <= 0.61.0; fixed in 0.62.0

## Suggested inspection (read-only)
- `python -m pip show datamodel-code-generator`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on datamodel-code-generator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-442q-2j6p-642g (GitHub-reviewed advisory GHSA-442q-2j6p-642g lists affected ranges: PyPI datamodel-code-generator >=0.59.0 <=0.61.0)

Commands are suggestions: review each one before running it.

Loading voting…