Pillow GdImageFile._open(): image dimensions accepted without _decompression_bomb_check()
CVE-2026-55380GHSA-phj9-mv4w-65pm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 12.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pillow
- Affected
- < 12.3.0
- Fixed in
- 12.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-phj9-mv4w-65pm lists affected ranges: PyPI pillow >=0 <12.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-phj9-mv4w-65pm lists affected ranges: PyPI pillow >=0 <12.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-55380: 0.52% estimated exploitation activity in the next 30 days; percentile 44.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description PIL/GdImageFile.py GdImageFile.open() reads image dimensions from the GD 2.x header and stores them in self.size without calling Image.decompressionbombcheck(). Because GdImageFile is not registered with Image.registeropen(), it never passes through the standard Image.open() code path that enforces Pillow's decompression bomb guard. The plugin exposes its own entry point — PIL.GdImageFile.open(fp) — which directly instantiates the class, fully bypassing the documented protection. Vulnerable code (PIL/GdImageFile.py lines 50–61): When load() is subsequently called on the returned image object: Dimension arithmetic: | Field | Value | |---|---| | Maximum width from header | 65,535 (unsigned 16-bit) | | Maximum height from header | 65,535 (unsigned 16-bit) | | Maximum pixel count | 65,535 × 65,535 = 4,294,836,225 | | DecompressionBombError threshold | 178,956,970 (2 × MAXIMAGEPIXELS) | | Overshoot ratio | 24× above DecompressionBombError threshold | | Memory at max dimensions…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-phj9-mv4w-65pm
- Revision 1 · created ·
Published from osv record GHSA-phj9-mv4w-65pm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55380 Advisory: Pillow `GdImageFile._open()`: image dimensions accepted without `_decompression_bomb_check()` IDs: CVE-2026-55380, GHSA-phj9-mv4w-65pm Record: https://patchnext.com/advisories/cve-2026-55380 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 12.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pillow: affected < 12.3.0; fixed in 12.3.0 ## Suggested inspection (read-only) - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-phj9-mv4w-65pm (OSV record GHSA-phj9-mv4w-65pm lists affected ranges: PyPI pillow >=0 <12.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-phj9-mv4w-65pm (GitHub-reviewed advisory GHSA-phj9-mv4w-65pm lists affected ranges: PyPI pillow >=0 <12.3.0) Commands are suggestions: review each one before running it.
Loading voting…