Skip to content

← Actionable
High, CVSS 8.4Exploited · CISA KEVamended

Langflow: IDOR Vulnerability in /api/v1/responses Endpoint Allows Authenticated Attackers to Access Another User's Flow

CVE-2026-55255GHSA-qrpv-q767-xqq2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langflow

    Affected
    < 1.9.1
    Fixed in
    1.9.1

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L
EPSS
  • CVE-2026-55255: 0.89% estimated exploitation activity in the next 30 days; percentile 59.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Insecure Direct Object Reference (IDOR) vulnerability in /api/v1/responses endpoint allows an authenticated attacker to execute any flow belonging to another user by specifying the victim's flow ID in the request. Details The vulnerability exists in the getflowbyidorendpointname helper function in src/backend/base/langflow/helpers/flow.py (lines 399-414). When a flow is accessed via UUID (flowid), the function queries the database directly without verifying if the authenticated user owns that flow: This function is used by the /api/v1/responses endpoint (defined in src/backend/base/langflow/api/v1/openairesponses.py:589). PoC (Proof of Concept) Impact Any authenticated user can: 1. Execute any flow in the system by knowing its flow ID 2. Access potentially sensitive data processed by victim's flows 3. Consume victim's resources Fixes Fixed in PR #12832 (fix(security): close IDOR in getflowbyidorendpointname), merged 2026-04-22, released in Langflow 1.9.1. The helper…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qrpv-q767-xqq2

  2. Revision 2 · evidence added ·

    CISA KEV confirmed exploitation for CVE-2026-55255 (date added 2026-07-07). Customer workflow unchanged.

  3. Revision 1 · created ·

    Published from osv record GHSA-qrpv-q767-xqq2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55255

Advisory: Langflow: IDOR Vulnerability in `/api/v1/responses` Endpoint Allows Authenticated Attackers to Access Another User's Flow
IDs: CVE-2026-55255, GHSA-qrpv-q767-xqq2
Record: https://patchnext.com/advisories/cve-2026-55255 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: langflow 1.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langflow: affected < 1.9.1; fixed in 1.9.1

## Suggested inspection (read-only)
- `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qrpv-q767-xqq2 (OSV record GHSA-qrpv-q767-xqq2 lists affected ranges: PyPI langflow >=0 <1.9.1 (fixed))
- Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2026-55255 to the Known Exploited Vulnerabilities catalog on 2026-07-07.)
- Verified: https://github.com/advisories/GHSA-qrpv-q767-xqq2 (GitHub-reviewed advisory GHSA-qrpv-q767-xqq2 lists affected ranges: PyPI langflow >=0 <1.9.1)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2026-55255 to the Known Exploited Vulnerabilities catalog on 2026-07-07.)

Commands are suggestions: review each one before running it.

Loading voting…