Skip to content

← Actionable
Critical, CVSS 9.1amended

plone.app.portlets vulnerable to denial of service via RSS feed portlet

CVE-2026-55248GHSA-x5g3-w747-2h8q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (plone-app-portlets 7.0.2, 6.0.4, 5.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI plone-app-portlets

    Affected
    >= 7.0.0, <= 7.0.1>= 6.0.0, < 6.0.4< 5.0.8
    Fixed in
    5.0.8, 7.0.2, 6.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H
EPSS
  • CVE-2026-55248: 0.44% estimated exploitation activity in the next 30 days; percentile 38.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact By adding an RSS portlet, and giving this a link to a very large file, a member can cause a denial of service attack, because Plone will use lots of memory. The member could also use different urls to try to get information about the internal network and open port numbers (SSRF). A malicious RSS feed could cause stored XSS, when the url of a feed item is a javascript url. Patches The problem has been patched in plone.app.portlets. For Plone 6.2: upgrade to plone.app.portlets 7.0.2 For Plone 6.1: upgrade to plone.app.portlets 6.0.4 For Plone 6.0: upgrade to plone.app.portlets 5.0.8 Workarounds If upgrading is not immediately possible: - Restrict who can manage portlets: remove the plone.app.portlets.ManageOwnPortlets permission from untrusted roles, and limit Manage portlets to trusted administrators (usually this is already restricted to the Manager and Site Administrator roles). - Where the RSS portlet is not needed, unregister it so it cannot be added. This would need to be…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x5g3-w747-2h8q

  2. Revision 2 · amended ·

    Amended from osv record GHSA-x5g3-w747-2h8q

  3. Revision 1 · created ·

    Published from ghsa record GHSA-x5g3-w747-2h8q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55248

Advisory: plone.app.portlets vulnerable to denial of service via RSS feed portlet
IDs: CVE-2026-55248, GHSA-x5g3-w747-2h8q
Record: https://patchnext.com/advisories/cve-2026-55248 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: plone-app-portlets 7.0.2, 6.0.4, 5.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI plone-app-portlets: affected >= 7.0.0, <= 7.0.1; >= 6.0.0, < 6.0.4; < 5.0.8; fixed in 5.0.8, 7.0.2, 6.0.4

## Suggested inspection (read-only)
- `python -m pip show plone-app-portlets`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on plone-app-portlets.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x5g3-w747-2h8q (GitHub-reviewed advisory GHSA-x5g3-w747-2h8q lists affected ranges: PyPI plone-app-portlets >=7.0.0 =6.0.0 =0 <5.0.8)
- Verified: https://osv.dev/vulnerability/GHSA-x5g3-w747-2h8q (OSV record GHSA-x5g3-w747-2h8q lists affected ranges: PyPI plone-app-portlets >=7.0.0 =6.0.0 =0 <5.0.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…