Skip to content

← Actionable
Medium, CVSS 5.9amended

langgraph-api: Incomplete assistant authorization in LangGraph Server run creation

CVE-2026-55236GHSA-jfj5-wrj9-63x4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph-api 0.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-55236: 0.26% estimated exploitation activity in the next 30 days; percentile 17.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In affected versions of `langgraph-api` (the LangGraph Server runtime), the run-creation path authorized the assistant attached to a run using a different authorization event than the rest of the assistant-handling code paths. Direct assistant reads and cron creation dispatch the `assistants.read` authorization event; run creation dispatched `assistants.search` with an incomplete value. In deployments whose custom authorization handlers register only an `assistants.read` handler (without an `assistants.search` handler and without a global fallback handler), no handler was consulted on the run-creation path, the returned filter set was empty, and the owner constraint was omitted from the resulting query. As a result, in those deployments a request to create a run could reference a private assistant owned by another user, even where direct assistant reads, assistant search, and cron creation against that assistant were correctly denied. The run-creation response merged the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-jfj5-wrj9-63x4

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-jfj5-wrj9-63x4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-jfj5-wrj9-63x4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55236

Advisory: langgraph-api: Incomplete assistant authorization in LangGraph Server run creation
IDs: CVE-2026-55236, GHSA-jfj5-wrj9-63x4
Record: https://patchnext.com/advisories/cve-2026-55236 (revision 3, source checked 29 Oct 2026, 06:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langgraph-api 0.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langgraph-api: affected < 0.10.0; fixed in 0.10.0

## Suggested inspection (read-only)
- `python -m pip show langgraph-api`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langgraph-api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jfj5-wrj9-63x4 (GitHub-reviewed advisory GHSA-jfj5-wrj9-63x4 lists affected ranges: PyPI langgraph-api >=0 <0.10.0)
- Verified: https://osv.dev/vulnerability/GHSA-jfj5-wrj9-63x4 (OSV record GHSA-jfj5-wrj9-63x4 lists affected ranges: PyPI langgraph-api >=0 <0.10.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…