langgraph-api: Relative webhook targets in LangGraph Server can reach in-process routes without authentication
CVE-2026-55235GHSA-2c9q-c2q9-qgqv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph-api 0.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langgraph-api
- Affected
- < 0.10.0
- Fixed in
- 0.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2c9q-c2q9-qgqv lists affected ranges: PyPI langgraph-api >=0 <0.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2c9q-c2q9-qgqv lists affected ranges: PyPI langgraph-api >=0 <0.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:L
- EPSS
- CVE-2026-55235: 0.36% estimated exploitation activity in the next 30 days; percentile 30.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In affected versions of `langgraph-api` (the LangGraph Server runtime), a run or cron could be created with a relative webhook target. When the server later delivers such a webhook, it routes the request back into the same application through an in-process loopback transport that the authentication middleware treats as internal and does not authenticate. As a result, a relative webhook target could reach the server's own routes that operate on threads and runs without the authentication context that applies to ordinary external requests. In deployments that scope threads and runs by owner, this could allow a request associated with one user to reach routes operating on another user's thread, resulting in creation of a run on (or modification of the state of) a thread owned by another user, even where the corresponding direct external requests were correctly denied. Limited metadata from the targeted thread may be incorporated into the created run record. We have no…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-2c9q-c2q9-qgqv
- Revision 2 · amended ·
Amended from ghsa record GHSA-2c9q-c2q9-qgqv
- Revision 1 · created ·
Published from ghsa record GHSA-2c9q-c2q9-qgqv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55235 Advisory: langgraph-api: Relative webhook targets in LangGraph Server can reach in-process routes without authentication IDs: CVE-2026-55235, GHSA-2c9q-c2q9-qgqv Record: https://patchnext.com/advisories/cve-2026-55235 (revision 3, source checked 29 Oct 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langgraph-api 0.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langgraph-api: affected < 0.10.0; fixed in 0.10.0 ## Suggested inspection (read-only) - `python -m pip show langgraph-api`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langgraph-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2c9q-c2q9-qgqv (GitHub-reviewed advisory GHSA-2c9q-c2q9-qgqv lists affected ranges: PyPI langgraph-api >=0 <0.10.0) - Verified: https://osv.dev/vulnerability/GHSA-2c9q-c2q9-qgqv (OSV record GHSA-2c9q-c2q9-qgqv lists affected ranges: PyPI langgraph-api >=0 <0.10.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…