Skip to content

← Actionable
High, CVSS 8.0

Strimzi: Cross-namespace privilege escalation via Kafka.spec.entityOperator

CVE-2026-55225GHSA-mw9r-p8xp-wx96

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.strimzi:strimzi 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-55225: 0.29% estimated exploitation activity in the next 30 days; percentile 22.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Having the Topic and User operators to watch different namespaces than the one where the Kafka cluster is deployed, is a fully documented feature. When the watchedNamespace field is used within the Topic or User operator (as part of the Kafka.spec.entityOperator field), the Cluster Operator creates a Role granting full CRUD on Secrets into the specified namespace. It also creates a RoleBinding to bind such Role to the entity operator ServiceAccount within the namespace where the Kafka cluster runs. An attacker can craft a Kafka custom resource (in an attacker's namespace) with the watchedNamespace field set to a target namespace and then they can mint a token for the ServiceAccount (in the attacker's namespace) to read/write Secrets in that target. This is valid with any target namespace for which the Cluster Operator has the rights (regardless the value of the STRIMZINAMESPACE environment variable). The at-risk target namespaces are the namespaces which the user has given…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mw9r-p8xp-wx96

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55225

Advisory: Strimzi: Cross-namespace privilege escalation via `Kafka.spec.entityOperator`
IDs: CVE-2026-55225, GHSA-mw9r-p8xp-wx96
Record: https://patchnext.com/advisories/cve-2026-55225 (revision 1, source checked 26 Oct 2026, 16:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.strimzi:strimzi 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.strimzi:strimzi: affected <= 1.0.0; fixed in 1.0.1

## Suggested inspection (read-only)
- Maven io.strimzi:strimzi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.strimzi:strimzi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mw9r-p8xp-wx96 (GitHub-reviewed advisory GHSA-mw9r-p8xp-wx96 lists affected ranges: Maven io.strimzi:strimzi >=0 <=1.0.0)

Commands are suggestions: review each one before running it.

Loading voting…