Skip to content

← Actionable
High, CVSS 8.7amended

MineAdmin Vulnerable to Path Traversal via Unsanitized identifier in Plugin Install/Uninstall

CVE-2026-55224GHSA-59xm-4m8c-g3xj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mineadmin/mineadmin 3.2.0-alpha.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-55224: 1.37% estimated exploitation activity in the next 30 days; percentile 71.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Path Traversal via Unsanitized Identifier in Plugin Install/Uninstall Summary The app-store plugin service concatenates unsanitized user-supplied identifier values directly into file system paths. An attacker can use path traversal sequences (e.g., ../) to read, install, or uninstall plugins from arbitrary directories, and potentially execute arbitrary composer commands. Vulnerable Code File: plugin/mine-admin/app-store/src/Service/Service.php File: plugin/mine-admin/app-store/src/Controller/IndexController.php (lines 25-26) Proof of Concept Impact - Path traversal enables reading directory existence outside the plugin directory - Plugin::install() with a traversed identifier may run composer commands on arbitrary directories - Combined with GM-4340 (missing PermissionMiddleware), any authenticated user can exploit this - Could lead to arbitrary code execution depending on Plugin::install() implementation Remediation Validate and sanitize the identifier parameter to reject path…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-59xm-4m8c-g3xj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-59xm-4m8c-g3xj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55224

Advisory: MineAdmin Vulnerable to Path Traversal via Unsanitized identifier in Plugin Install/Uninstall
IDs: CVE-2026-55224, GHSA-59xm-4m8c-g3xj
Record: https://patchnext.com/advisories/cve-2026-55224 (revision 3, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mineadmin/mineadmin 3.2.0-alpha.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mineadmin/mineadmin: affected < 3.2.0-alpha.2; fixed in 3.2.0-alpha.2

## Suggested inspection (read-only)
- Packagist mineadmin/mineadmin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mineadmin/mineadmin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-59xm-4m8c-g3xj (OSV record GHSA-59xm-4m8c-g3xj lists affected ranges: Packagist mineadmin/mineadmin >=0 <3.2.0-alpha.2 (fixed))
- Verified: https://github.com/advisories/GHSA-59xm-4m8c-g3xj (GitHub-reviewed advisory GHSA-59xm-4m8c-g3xj lists affected ranges: Packagist mineadmin/mineadmin >=0 <3.2.0-alpha.2)

Commands are suggestions: review each one before running it.

Loading voting…