Skip to content

← Actionable
Medium, CVSS 5.3

Paymenter has race condition in payWithCredit() that enables credit double-spend

CVE-2026-55219GHSA-pgcq-8grm-5rx9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (paymenter/paymenter 1.5.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-55219: 0.21% estimated exploitation activity in the next 30 days; percentile 11.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The credit payment implementation in app/Livewire/Invoices/Show.php executes a pessimistic row lock (lockForUpdate()) outside of an active database transaction. Because MySQL/MariaDB requires an enclosing transaction to enforce row-level locks, the guard is ineffective. Concurrent payment requests can exploit this race condition to read the same credit balance simultaneously, allowing users to pay multiple invoices using the same credit balance. Technical Details The issue occurs because the application attempts to lock the user's credit balance row in the database (lockForUpdate()) without opening a database transaction. In database systems like MySQL, a row lock only works inside a formal transaction; without one, the lock is completely ignored. Because there is no active lock, two payment requests sent at the exact same millisecond can look at the database at the same time. Both requests see the original credit balance, decide it is sufficient, and approve the payment.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pgcq-8grm-5rx9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55219

Advisory: Paymenter has race condition in payWithCredit() that enables credit double-spend
IDs: CVE-2026-55219, GHSA-pgcq-8grm-5rx9
Record: https://patchnext.com/advisories/cve-2026-55219 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: paymenter/paymenter 1.5.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist paymenter/paymenter: affected <= 1.5.4; fixed in 1.5.5

## Suggested inspection (read-only)
- Packagist paymenter/paymenter: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on paymenter/paymenter.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pgcq-8grm-5rx9 (GitHub-reviewed advisory GHSA-pgcq-8grm-5rx9 lists affected ranges: Packagist paymenter/paymenter >=0 <=1.5.4)

Commands are suggestions: review each one before running it.

Loading voting…