Skip to content

← Actionable
High, CVSS 7.5

MariaDB's connector leaks the cleartext password to an MitM despite ssl: true

CVE-2026-55215GHSA-cqhc-2h57-wpxf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mariadb 3.5.3, 3.4.6, 3.3.3, 3.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mariadb

    Affected
    < 3.2.4>= 3.3.0, < 3.3.3>= 3.4.0, < 3.4.6>= 3.5.0, < 3.5.3
    Fixed in
    3.2.4, 3.5.3, 3.3.3, 3.4.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-55215: 0.57% estimated exploitation activity in the next 30 days; percentile 47.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When SSL/TLS is enabled but no CA / server certificate is provided, the connector verifies the server's identity using fingerprint validation. The check is effective, the connection is ultimately rejected when it fails, but it happens after the authentication exchange. As a result, the credentials are sent before validation occurs, so an active man-in-the-middle who presents their own certificate receives the password in the handshake before the connection is aborted. Impact The credentials are transmitted to the peer before the server's identity is validated. An on-path attacker (MitM) presenting any certificate can capture the account password, even though the connection then fails the fingerprint check and is closed. The disclosed credentials can subsequently be used to authenticate directly against the server. - Attacker requirement: active man-in-the-middle position on the network path - Affected configuration: SSL/TLS enabled without a CA / server certificate Affected…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cqhc-2h57-wpxf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55215

Advisory: MariaDB's connector leaks the cleartext password to an MitM despite `ssl: true`
IDs: CVE-2026-55215, GHSA-cqhc-2h57-wpxf
Record: https://patchnext.com/advisories/cve-2026-55215 (revision 1, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mariadb 3.5.3, 3.4.6, 3.3.3, 3.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mariadb: affected < 3.2.4; >= 3.3.0, < 3.3.3; >= 3.4.0, < 3.4.6; >= 3.5.0, < 3.5.3; fixed in 3.2.4, 3.5.3, 3.3.3, 3.4.6

## Suggested inspection (read-only)
- `npm ls mariadb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mariadb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cqhc-2h57-wpxf (GitHub-reviewed advisory GHSA-cqhc-2h57-wpxf lists affected ranges: npm mariadb >=0 =3.3.0 =3.4.0 =3.5.0 <3.5.3)

Commands are suggestions: review each one before running it.

Loading voting…