Skip to content

← Actionable
Medium, CVSS 4.2amended

MultiFactor Authentication for SilverStripe can bypass MFA during password reset flow

CVE-2026-55186GHSA-68wq-phq7-p2vg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/mfa 6.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact In CMS 5, the password reset flow let a user with multi-factor authentication enabled change their password and get a logged-in session before completing multi-factor authentication. Exploiting this requires access to the user's email account. CMS 6 is not affected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-68wq-phq7-p2vg

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-68wq-phq7-p2vg

  3. Revision 2 · amended ·

    Amended from osv record GHSA-68wq-phq7-p2vg

  4. Revision 1 · created ·

    Published from ghsa record GHSA-68wq-phq7-p2vg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55186

Advisory: MultiFactor Authentication for SilverStripe can bypass MFA during password reset flow
IDs: CVE-2026-55186, GHSA-68wq-phq7-p2vg
Record: https://patchnext.com/advisories/cve-2026-55186 (revision 4, source checked 4 Nov 2026, 06:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/mfa 6.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/mfa: affected < 6.0.0; fixed in 6.0.0

## Suggested inspection (read-only)
- Packagist silverstripe/mfa: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/mfa.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-68wq-phq7-p2vg (GitHub-reviewed advisory GHSA-68wq-phq7-p2vg lists affected ranges: Packagist silverstripe/mfa >=0 <6.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-68wq-phq7-p2vg (OSV record GHSA-68wq-phq7-p2vg lists affected ranges: Packagist silverstripe/mfa >=0 <6.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…