GeoLens: Cross-dataset authorization bypass discloses private dataset metadata, schema, sample values, table rows, and raster/vector tile data
CVE-2026-55178GHSA-p23g-mvhj-jh3j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (geolens 1.2.3; geolens-cli 1.2.3; @geolens/sdk 1.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI geolens
- Affected
- < 1.2.3
- Fixed in
- 1.2.3
PyPI geolens-cli
- Affected
- < 1.2.3
- Fixed in
- 1.2.3
npm @geolens/sdk
- Affected
- < 1.2.3
- Fixed in
- 1.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p23g-mvhj-jh3j lists affected ranges: npm @geolens/sdk >=0 =0 =0 <1.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-55178: 0.65% estimated exploitation activity in the next 30 days; percentile 51.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Multiple GeoLens read/link endpoints authorized only the resource named in the request URL (a map, a VRT, a source dataset, an AI request) and failed to re-authorize a second, caller-influenced dataset that the request reached through a relationship, layer reference, mosaic source, or request body. This "authorize the URL resource, read a different dataset un-re-authorized" pattern let callers read data from datasets they have no access to. The most severe instances require no authentication at all (anonymous, network-only). Others require only the default editor role that any self-service signup / upload user receives. All issues are fixed in 1.2.3. There is no complete configuration workaround — upgrading is the only full remediation. Impact Depending on the endpoint, an attacker can read, for datasets they cannot otherwise access: - the dataset's vector tile data (actual feature geometries/attributes), - the dataset's raster pixels, - backing-table rows, - and metadata —…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p23g-mvhj-jh3j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55178 Advisory: GeoLens: Cross-dataset authorization bypass discloses private dataset metadata, schema, sample values, table rows, and raster/vector tile data IDs: CVE-2026-55178, GHSA-p23g-mvhj-jh3j Record: https://patchnext.com/advisories/cve-2026-55178 (revision 1, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: geolens 1.2.3; geolens-cli 1.2.3; @geolens/sdk 1.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI geolens: affected < 1.2.3; fixed in 1.2.3 - PyPI geolens-cli: affected < 1.2.3; fixed in 1.2.3 - npm @geolens/sdk: affected < 1.2.3; fixed in 1.2.3 ## Suggested inspection (read-only) - `python -m pip show geolens`: prints the installed version. Run with the environment that serves production active. - `python -m pip show geolens-cli`: prints the installed version. Run with the environment that serves production active. - `npm ls @geolens/sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on geolens, geolens-cli, @geolens/sdk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p23g-mvhj-jh3j (GitHub-reviewed advisory GHSA-p23g-mvhj-jh3j lists affected ranges: npm @geolens/sdk >=0 =0 =0 <1.2.3) Commands are suggestions: review each one before running it.
Loading voting…