Lemur Privilege Escalation: Non-admin role members can rewrite role membership via PUT /api/1/roles/
CVE-2026-55163GHSA-x3vf-mgxj-7785
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemur 1.9.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lemur
- Affected
- <= 1.9.1
- Fixed in
- 1.9.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x3vf-mgxj-7785 lists affected ranges: PyPI lemur >=0 <1.9.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x3vf-mgxj-7785 lists affected ranges: PyPI lemur >=0 <=1.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-55163: 0.22% estimated exploitation activity in the next 30 days; percentile 12.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The PUT /api/1/roles/<id handler in lemur/roles/views.py gates only on RoleMemberPermission(roleid).can(), which is satisfied for any user who is already a member of the target role. The handler then passes data["users"] and data["name"] directly to service.update(), permitting any role member to rewrite that role's membership list and name. The companion DELETE handler on the same resource is correctly gated by @adminpermission.require; the asymmetry between PUT and DELETE on identical resources indicates an authorization oversight rather than a deliberate design choice. Root Cause lemur/roles/views.py:298: lemur/auth/permissions.py:56: flaskprincipal.Permission.allows() is OR-semantic across needs, so RoleMemberPermission(roleid).can() returns True if the caller is either an admin or a member of roleid. The PUT handler treats membership-of-self as sufficient to mutate the role; DELETE does not. Affected Endpoints | Method | Path | Source | |---|---|---| | PUT |…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x3vf-mgxj-7785
- Revision 1 · created ·
Published from osv record GHSA-x3vf-mgxj-7785
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55163 Advisory: Lemur Privilege Escalation: Non-admin role members can rewrite role membership via PUT /api/1/roles/ IDs: CVE-2026-55163, GHSA-x3vf-mgxj-7785 Record: https://patchnext.com/advisories/cve-2026-55163 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lemur 1.9.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lemur: affected <= 1.9.1; fixed in 1.9.2 ## Suggested inspection (read-only) - `python -m pip show lemur`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lemur. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x3vf-mgxj-7785 (OSV record GHSA-x3vf-mgxj-7785 lists affected ranges: PyPI lemur >=0 <1.9.2 (fixed)) - Verified: https://github.com/advisories/GHSA-x3vf-mgxj-7785 (GitHub-reviewed advisory GHSA-x3vf-mgxj-7785 lists affected ranges: PyPI lemur >=0 <=1.9.1) Commands are suggestions: review each one before running it.
Loading voting…