Skip to content

← Actionable
Medium, CVSS 6.3amended

Lemur: Crafted CRL/OCSP URLs in uploaded certificates lead to post-authentication SSRF

CVE-2026-55162GHSA-54vg-pfh7-jq95

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemur 1.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lemur

    Affected
    <= 1.9.1
    Fixed in
    1.9.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-55162: 0.22% estimated exploitation activity in the next 30 days; percentile 12.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When verifying an uploaded certificate, lemur/certificates/verify.py extracts the CRL Distribution Point URL and the OCSP responder URL directly from the certificate's extensions and issues outbound requests to those URLs without scheme restriction or destination allow-listing. An authenticated user holding the operator role (required by StrictRolePermission on POST /certificates/upload) can craft a certificate whose extensions point at internal services - instance metadata endpoints, internal Kubernetes API servers, RFC1918 hosts, link-local addresses - and cause the Lemur host to issue requests against those destinations during verification. Root Cause lemur/certificates/verify.py, crlverify: lemur/certificates/verify.py, ocspverify: In both code paths the URL flows from attacker-controlled certificate-extension content to a network sink with no validation against an allow-list of hostnames, no scheme restriction beyond rejecting LDAP via InvalidSchema, and no filtering of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-54vg-pfh7-jq95

  2. Revision 1 · created ·

    Published from osv record GHSA-54vg-pfh7-jq95

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55162

Advisory: Lemur: Crafted CRL/OCSP URLs in uploaded certificates lead to post-authentication SSRF
IDs: CVE-2026-55162, GHSA-54vg-pfh7-jq95
Record: https://patchnext.com/advisories/cve-2026-55162 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lemur 1.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lemur: affected <= 1.9.1; fixed in 1.9.2

## Suggested inspection (read-only)
- `python -m pip show lemur`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lemur.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-54vg-pfh7-jq95 (OSV record GHSA-54vg-pfh7-jq95 lists affected ranges: PyPI lemur >=0 <1.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-54vg-pfh7-jq95 (GitHub-reviewed advisory GHSA-54vg-pfh7-jq95 lists affected ranges: PyPI lemur >=0 <=1.9.1)

Commands are suggestions: review each one before running it.

Loading voting…