conflibot vulnerable to command injection via crafted pull request branch names under pull_request_target
CVE-2026-55158GHSA-2qvg-qr73-mqxp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wktk/conflibot 1.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
GitHub Actions wktk/conflibot
- Affected
- < 1.2.1
- Fixed in
- 1.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2qvg-qr73-mqxp lists affected ranges: GitHub Actions wktk/conflibot >=0 <1.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2qvg-qr73-mqxp lists affected ranges: GitHub Actions wktk/conflibot >=0 <1.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-55158: 0.80% estimated exploitation activity in the next 30 days; percentile 56.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Versions of conflibot before 1.2.1 build git commands by string interpolation and run them through a shell. Several of the interpolated values are pull request branch names (head.ref), which are attacker-controlled: anyone can open a pull request (including from a fork) whose head branch name contains shell metacharacters such as , $( ), ;, |, or &. The recommended workflow runs conflibot on the pullrequesttarget event, where the job has access to the base repository's secrets and a write-scoped GITHUBTOKEN. As a result, a crafted branch name causes arbitrary command execution on the runner with that write token in the environment, allowing an attacker to exfiltrate secrets and the token, push to the repository, or otherwise abuse the token's permissions. No special privileges and no maintainer interaction are required — the action runs automatically when the pull request is opened. Affected configurations Any workflow using wktk/conflibot at a version earlier than 1.2.1. The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2qvg-qr73-mqxp
- Revision 1 · created ·
Published from osv record GHSA-2qvg-qr73-mqxp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55158 Advisory: conflibot vulnerable to command injection via crafted pull request branch names under pull_request_target IDs: CVE-2026-55158, GHSA-2qvg-qr73-mqxp Record: https://patchnext.com/advisories/cve-2026-55158 (revision 2, source checked 26 Oct 2026, 17:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wktk/conflibot 1.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - GitHub Actions wktk/conflibot: affected < 1.2.1; fixed in 1.2.1 ## Suggested inspection (read-only) - GitHub Actions wktk/conflibot: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wktk/conflibot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2qvg-qr73-mqxp (OSV record GHSA-2qvg-qr73-mqxp lists affected ranges: GitHub Actions wktk/conflibot >=0 <1.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-2qvg-qr73-mqxp (GitHub-reviewed advisory GHSA-2qvg-qr73-mqxp lists affected ranges: GitHub Actions wktk/conflibot >=0 <1.2.1) Commands are suggestions: review each one before running it.
Loading voting…