Skip to content

← Actionable
Medium, CVSS 6.1

tract-nnef: integer overflow in NNEF .dat tensor parser yields an out-of-bounds read on model load

CVE-2026-55093GHSA-x5mv-8wgw-29hg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tract-nnef 0.23.1, 0.22.2, 0.21.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io tract-nnef

    Affected
    >= 0.23.0, < 0.23.1>= 0.22.0, < 0.22.2< 0.21.16
    Fixed in
    0.21.16, 0.22.2, 0.23.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H
EPSS
  • CVE-2026-55093: 0.18% estimated exploitation activity in the next 30 days; percentile 7.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

- Component: tract-nnef (nnef/src/tensors.rs::readtensor) + tract-data (data/src/tensor.rs) - Affected versions: < 0.21.16, 0.22.0–0.22.2, 0.23.0–0.23.1 — the dense DatLoader path was unguarded across all three release lines; patched in 0.21.16 / 0.22.2 / 0.23.1 - Class: CWE-190 (integer overflow) → CWE-125 (out-of-bounds read) - Trigger: loading a crafted NNEF model archive (.nnef.tgz / .nnef.tar / dir) via the public tractnnef::nnef().modelforpath / modelforread - Impact: readtensor returns a memory-unsafe tensor (reported len 2^61 over a 56-byte heap allocation). Always-on primitive: a bounded heap out-of-bounds read during model build (asuniform), an adjacent-heap information-disclosure reachable via the public load API. The resulting slice is an unsound fromrawparts(ptr, 2^61) that SIGSEGVs (DoS) on any access past the mapped region (demonstrated by direct access). No out-of-bounds write and no RCE were achieved — tract's const-folding/asuniform fast-paths fold simple consuming…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x5mv-8wgw-29hg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55093

Advisory: tract-nnef: integer overflow in NNEF `.dat` tensor parser yields an out-of-bounds read on model load
IDs: CVE-2026-55093, GHSA-x5mv-8wgw-29hg
Record: https://patchnext.com/advisories/cve-2026-55093 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tract-nnef 0.23.1, 0.22.2, 0.21.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io tract-nnef: affected >= 0.23.0, < 0.23.1; >= 0.22.0, < 0.22.2; < 0.21.16; fixed in 0.21.16, 0.22.2, 0.23.1

## Suggested inspection (read-only)
- crates.io tract-nnef: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tract-nnef.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x5mv-8wgw-29hg (GitHub-reviewed advisory GHSA-x5mv-8wgw-29hg lists affected ranges: crates.io tract-nnef >=0.23.0 =0.22.0 =0 <0.21.16)

Commands are suggestions: review each one before running it.

Loading voting…