Skip to content

← Actionable
High, CVSS 8.7amended

Etherpad has stored XSS in HTML export via unescaped attribute-pool values

CVE-2026-55090GHSA-2jp7-wwpg-3p9w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ep_etherpad-lite 3.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-55090: 0.55% estimated exploitation activity in the next 30 days; percentile 45.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Fix: PR #7905 (ether/etherpad). getHTMLFromAtext in src/node/utils/ExportHtml.ts interpolates values from the exportHtmlAdditionalTagsWithData plugin hook into span data-<k="<v" without HTML-attribute escaping. The value comes verbatim from the pad attribute pool, which a pad editor controls via a crafted changeset (only author attributes are validated; moveOpsToNewPool - AttributePool.putAttrib stores any value). With a bundled plugin that registers the hook (epfontcolor / epfontsize), an attribute value such as " onload="alert(1) is exported as <span data-color="" onload="alert(1)" and served as text/html, yielding stored XSS for any collaborator who opens the export. Fix: escape the name and value via Security.escapeHTMLAttribute. PR #7905 also adds a startup warning when default/placeholder account or SSO credentials are configured (defense-in-depth, non-breaking).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2jp7-wwpg-3p9w

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2jp7-wwpg-3p9w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55090

Advisory: Etherpad has stored XSS in HTML export via unescaped attribute-pool values
IDs: CVE-2026-55090, GHSA-2jp7-wwpg-3p9w
Record: https://patchnext.com/advisories/cve-2026-55090 (revision 3, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ep_etherpad-lite 3.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ep_etherpad-lite: affected <= 1.8.14; fixed in 3.3.0

## Suggested inspection (read-only)
- `npm ls ep_etherpad-lite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ep_etherpad-lite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2jp7-wwpg-3p9w (OSV record GHSA-2jp7-wwpg-3p9w lists affected ranges: npm ep_etherpad-lite >=0 <3.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2jp7-wwpg-3p9w (GitHub-reviewed advisory GHSA-2jp7-wwpg-3p9w lists affected ranges: npm ep_etherpad-lite >=0 <=1.8.14)

Commands are suggestions: review each one before running it.

Loading voting…