Skip to content

← Actionable
High, CVSS 7.2

Coder: User-admin role can reset owner account password

CVE-2026-55077GHSA-29xf-69gq-m9jx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/coder/coder/v2 2.34.2, 2.33.8, 2.32.7, 2.29.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/coder/coder/v2

    Affected
    >= 2.34.0, < 2.34.2>= 2.33.0, < 2.33.8>= 2.30.0, < 2.32.7< 2.29.17
    Fixed in
    2.33.8, 2.29.17, 2.34.2, 2.32.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-55077: 0.61% estimated exploitation activity in the next 30 days; percentile 49.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The PUT /api/v2/users/{user}/password endpoint authorized only ActionUpdatePersonal and did not prevent a user-admin from resetting an owner account's password. It also did not require the current password when an admin reset another user's password. Note: Exploitation requires the privileged user-admin role so practical risk is limited to deployments that grant user-admin to less trusted operators. Impact A user-admin could reset any owner's password without knowing it, authenticate as that owner and gain full deployment control, including templates, workspaces, licensing, organization settings and the ability to self-assign the owner role. This was a privilege escalation from user-admin to owner. Patches The fix prevents non-owner users from resetting the password of an account that holds the owner role. The fix was backported to all supported release lines: | Release line | Patched version | |---|---| | 2.34 | v2.34.2 | | 2.33 | v2.33.8 | | 2.32 | v2.32.7 | | 2.29 (ESR) |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-29xf-69gq-m9jx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55077

Advisory: Coder: User-admin role can reset owner account password
IDs: CVE-2026-55077, GHSA-29xf-69gq-m9jx
Record: https://patchnext.com/advisories/cve-2026-55077 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/coder/coder/v2 2.34.2, 2.33.8, 2.32.7, 2.29.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/coder/coder/v2: affected >= 2.34.0, < 2.34.2; >= 2.33.0, < 2.33.8; >= 2.30.0, < 2.32.7; < 2.29.17; fixed in 2.33.8, 2.29.17, 2.34.2, 2.32.7

## Suggested inspection (read-only)
- Go github.com/coder/coder/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/coder/coder/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-29xf-69gq-m9jx (GitHub-reviewed advisory GHSA-29xf-69gq-m9jx lists affected ranges: Go github.com/coder/coder/v2 >=2.34.0 =2.33.0 =2.30.0 =0 <2.29.17)

Commands are suggestions: review each one before running it.

Loading voting…