Skip to content

← Actionable
High, CVSS 7.4

Coder vulnerable to OIDC account takeover via email-based user matching and email_verified bypass

CVE-2026-55075GHSA-9r87-mvcw-x35f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/coder/coder/v2 2.34.2, 2.33.8, 2.32.7, 2.29.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/coder/coder/v2

    Affected
    >= 2.34.0, < 2.34.2>= 2.33.0, < 2.33.8>= 2.30.0, < 2.32.7< 2.29.17
    Fixed in
    2.33.8, 2.29.17, 2.34.2, 2.32.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-55075: 0.48% estimated exploitation activity in the next 30 days; percentile 41.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Two flaws in Coder's OIDC login chained into account takeover: email-based user matching fell back to linking by email without checking for an existing link to a different IdP subject and the emailverified claim was only enforced when present as a boolean false so an absent or non-boolean claim was treated as verified. Impact An attacker who could authenticate at the configured OIDC provider with an email matching a victim's Coder account could log in as that victim and gain full access to their workspaces, templates and resources. This required OIDC authentication, attacker control of a matching email at the IdP and a victim account not yet linked to a different IdP subject. Patches The fix restricts the email fallback to first-time and legacy linking and defaults emailverified to false when the claim is absent or of an unexpected type. The fix was backported to all supported release lines: | Release line | Patched version | |---|---| | 2.34 | v2.34.2 | | 2.33 | v2.33.8 | |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9r87-mvcw-x35f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55075

Advisory: Coder vulnerable to OIDC account takeover via email-based user matching and email_verified bypass
IDs: CVE-2026-55075, GHSA-9r87-mvcw-x35f
Record: https://patchnext.com/advisories/cve-2026-55075 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/coder/coder/v2 2.34.2, 2.33.8, 2.32.7, 2.29.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/coder/coder/v2: affected >= 2.34.0, < 2.34.2; >= 2.33.0, < 2.33.8; >= 2.30.0, < 2.32.7; < 2.29.17; fixed in 2.33.8, 2.29.17, 2.34.2, 2.32.7

## Suggested inspection (read-only)
- Go github.com/coder/coder/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/coder/coder/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9r87-mvcw-x35f (GitHub-reviewed advisory GHSA-9r87-mvcw-x35f lists affected ranges: Go github.com/coder/coder/v2 >=2.34.0 =2.33.0 =2.30.0 =0 <2.29.17)

Commands are suggestions: review each one before running it.

Loading voting…