Skip to content

← Actionable
High, CVSS 8.1amended

Vikunja vulnerable to Improper Authorization and Authorization Bypass Through User-Controlled Key

CVE-2026-55065GHSA-gg93-x632-9ccv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.vikunja.io/api 2.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-55065: 0.50% estimated exploitation activity in the next 30 days; percentile 43.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A user with only a single self-owned project can permanently destroy the Kanban bucket assignments (taskbuckets) and task ordering (taskpositions) of any other project view in the entire instance. The ProjectView.Delete model method runs three SQL statements: the first is properly scoped to (viewid, projectid), but the next two cascading deletes on taskbuckets and taskpositions filter only on the URL-supplied projectviewid. The permission check (CanDelete) gates on Admin of the URL :project but never confirms that the URL :view actually belongs to that project. Details ProjectView.Delete (file: pkg/models/projectview.go, line 250) cascades on the bare pv.ID for the second and third deletes, ignoring pv.ProjectID: pv.ID and pv.ProjectID come straight from the URL path via c.Bind — see the param tags on the struct (pkg/models/projectview.go, lines 133–137): The route is registered with both params in pkg/routes/routes.go, line 791: CanDelete (file:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gg93-x632-9ccv

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6313

  3. Revision 1 · created ·

    Published from osv record GHSA-gg93-x632-9ccv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55065

Advisory: Vikunja vulnerable to Improper Authorization and Authorization Bypass Through User-Controlled Key
IDs: CVE-2026-55065, GHSA-gg93-x632-9ccv
Record: https://patchnext.com/advisories/cve-2026-55065 (revision 3, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code.vikunja.io/api 2.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go code.vikunja.io/api: affected >= 0.24.6, < 2.4.0; fixed in 2.4.0

## Suggested inspection (read-only)
- Go code.vikunja.io/api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code.vikunja.io/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gg93-x632-9ccv (OSV record GHSA-gg93-x632-9ccv lists affected ranges: Go code.vikunja.io/api >=0.24.6 <2.4.0 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6313 (OSV record GO-2026-6313 lists affected ranges: Go code.vikunja.io/api >=0.24.6)
- Verified: https://github.com/advisories/GHSA-gg93-x632-9ccv (GitHub-reviewed advisory GHSA-gg93-x632-9ccv lists affected ranges: Go code.vikunja.io/api >=0.24.6 <2.4.0)

Commands are suggestions: review each one before running it.

Loading voting…